php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15246 Not buffering causes IE refreshing madness!!
Submitted: 2002-01-27 12:06 UTC Modified: 2002-02-05 18:40 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: danytuppeny at ntlworld dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.0.6 OS: Win XP Pro
Private report: No CVE-ID: None
 [2002-01-27 12:06 UTC] danytuppeny at ntlworld dot com
Ok, this is a tricky one...

I had this weird problem where my browser (IE5.5 & IE6) went into a crazy fit and was refreshing like mad, cpu usage went up to 100% until I hit stop.

I could never figure it out, so I ignored it.

I got the same thing again today. I've got Apache & PHP running on my laptop (Win XP Pro), and although it worked fine locally, when someone accessed it, they got the mad refreshing loop (only in IE).

I've been messing about all afternoon with telnet logs and such, and I fixed it...

I set the output buffer to On and it went away. This is not a fluke, loads of people had the problem, now none of them do it.

You won't be able to reproduce it, so if you drop me an email, I'll turn buffering off and send you an url to see it.

I'm not sure if it's an IE thing, or a PHP thing, but since buffering solves it, I'm looking towards PHP.

I've got telnet logs of when it happened, and when it didn't (they're a big long to paste here) which I can supply if needed (both almost identicle)

If someone emails me when they're online, I'll turn buffering off and let them try it (provided I'm at home when they mail)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-05 18:40 UTC] yohgaki@php.net
The version of PHP that this bug was reported in is too old. Please
try to reproduce this bug in the latest version of PHP (available
from http://www.php.net/downloads.php

If you are still able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
 [2004-10-03 11:44 UTC] singh at softlinedigital dot com
Setting following in PHP.INI will fix this problem
output_buffering = On
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 17:01:31 2019 UTC