php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15243 Compile Error - make[3]: *** [pdf.lo] Error 1
Submitted: 2002-01-27 08:58 UTC Modified: 2002-06-04 04:33 UTC
From: achapman at dream-fusion dot com Assigned:
Status: Not a bug Package: *PDF functions
PHP Version: 4.1.1 OS: Red Hat 7.1
Private report: No CVE-ID: None
 [2002-01-27 08:58 UTC] achapman at dream-fusion dot com
Hi guys, sorry to be a pain but i've spent hours and hours trying to find a solution to this problem.  I have installed Apache SSL 1.3.22, the latest copy of pdflib and php-4.1.1 on my Red Hat server.  I'm compiling everything from source code, not binaries or rpm's.  

When configuring php, if i use --with-pdflib=/usr/local/lib then everything compiles fine, but php doesn't show any info about pdflib on the phpinfo() screen.  Naturally all pdf functions fail.

If I change the configure script to --with-pdflib=/usr/local, as specified by many other discussion threads, i get this:

pdf.c:208: warning: initialization makes integer from pointer without a cast
pdf.c:208: initializer element is not computable at load time
pdf.c:208: (near initialization for `pdf_module_entry.size')
pdf.c:209: warning: initialization makes integer from pointer without a cast
pdf.c:210: warning: initialization makes integer from pointer without a cast
pdf.c:210: initializer element is not computable at load time
pdf.c:210: (near initialization for `pdf_module_entry.zend_debug')
pdf.c:211: warning: initialization makes integer from pointer without a cast
pdf.c:211: initializer element is not computable at load time
pdf.c:211: (near initialization for `pdf_module_entry.zts')
pdf.c:214: warning: initialization from incompatible pointer type
make[3]: *** [pdf.lo] Error 1
make[3]: Leaving directory `/usr/local/php-4.1.1/ext/pdf'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/php-4.1.1/ext/pdf'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/php-4.1.1/ext'
make: *** [all-recursive] Error 1

Here is my complete configure script:

./configure --prefix=/usr/local/apache --with-mysql --with-mcrypt=/usr/home/nycran/temp/mcrypt/mcrypt-2.5.10/libmcrypt-2.4.17/ --with-gd --with-jpeg-dir=/usr --with-png --with-zlib --enable-magic-quotes --enable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-ftp --with-apache=../apache_1.3.22 --enable-track-vars --with-pdflib=/usr/local

Is this a php compilation bug or a pdflib support issue?  Or am i doing something really stupid?

Cheers,
Andy Chapman.
achapman@dream-fusion.com


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-04 04:33 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 04:01:26 2019 UTC