php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15190 Configure script fails to find static libming
Submitted: 2002-01-23 17:22 UTC Modified: 2002-03-09 13:17 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: doc at vulcanmicro dot com Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 4.1.1 OS: Any
Private report: No CVE-ID: None
 [2002-01-23 17:22 UTC] doc at vulcanmicro dot com
On line 30452 in the configure script, it searchs for libming.so but not libming.a, so if you compiled a static version of the ming library, the configure script won't find it.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-23 19:57 UTC] yohgaki@php.net
There are extensions that search only *.so libs.
Build and use shared lib for now.
 [2002-01-24 09:57 UTC] doc at vulcanmicro dot com
Three reasons to use static libraries.

1) Some platforms have problems building some libraries as shared libs.
2) Some platforms are can't build shared libs.
3) If you want a binary that is portable from machine to machine, the best way to do that is to statically link to any nonstandard libs. Even if you copy the shared libs to the new machine along with your binary, sometimes they don't
work because the new machine is using a different version of libc, for instance.
4) Static links reduce disk access at program load time and can make the program load faster.

Besides, how hard is it to add another if statement if the configure script. I did it in about 30 seconds. Jeez.
 [2002-01-24 09:58 UTC] doc at vulcanmicro dot com
Ok, so I lied, thats four reasons.
 [2002-03-09 13:17 UTC] sniper@php.net
Fixed in CVS. Fix will be in PHP 4.2.0 release.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 03:03:58 2022 UTC