php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15159 apache chush and write when i use header('') function;
Submitted: 2002-01-22 05:47 UTC Modified: 2002-02-03 15:24 UTC
From: kostia at obninsk dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.1.1 OS: linux 2.2.16-20
Private report: No CVE-ID: None
 [2002-01-22 05:47 UTC] kostia at obninsk dot com
function DoAuthorise(){
    header( "WWW-Authenticate: Basic realm=\"Catalog Administaror Login\"" );
    header( "HTTP/1.0 401 Unauthorized" );
    echo "Authorization require";
    exit;
}

this is not work in php 4.1.1 !!! 
Apache log:  [notice] child pid 6527 exit signal Segmentation fault (11)

When i comment all header invocation  all fine
my apache configuration:

Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a PHP/4.1.1 mod_perl/1.24

when a change my php module to previous version 4.0.6 
the code above work OK! 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-22 09:57 UTC] imajes@php.net
this isn't a website problem, but potentially an apache problem.
 [2002-01-23 03:39 UTC] sesser@php.net
1) Next time FIRST search the bug database.

2) That bug was fixed some days ago in CVS.
   (its a one line fix in SAPI.c)
 [2002-01-23 10:05 UTC] sniper@php.net
closed then. (duplicate == still open issue)


 [2002-02-03 15:11 UTC] bugzilla at uxp dot de
I have exactly the same problem.

Would you mind to mention the Bug # and/or which line in sapi.c is affected ? I can't find a duplicate bug.
 [2002-02-03 18:34 UTC] bugzilla at uxp dot de
Thanks
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 04:03:37 2022 UTC