php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15146 Apache fails to start - lib/php/libphp4.so: undefined symbol: pthread_getspecif
Submitted: 2002-01-21 10:20 UTC Modified: 2002-01-21 11:15 UTC
From: ams at izoard dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.1.1 OS: Debian Linux 2.2.19
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ams at izoard dot com
New email:
PHP Version: OS:

 

 [2002-01-21 10:20 UTC] ams at izoard dot com
Apache 1.3.22 with PHP 4.1.1 fails to start:

bash$ /vol/stage/apache/bin/apachectl sslstart
Syntax error on line 242 of /vol/stage/apache/conf/httpd.conf:
Cannot load /vol/stage/apache/lib/php/libphp4.so into server: /vol/stage/apache/lib/php/libphp4.so: undefined symbol: pthread_getspecific
/vol/stage/apache/bin/apachectl sslstart: httpd could not be started

Configured as follows:

 CFLAGS=-DEAPI ./configure --with-mysql --with-axs=/vol/stage/apache/bin/apxs --with-imap --with-libjpeg=/usr/local/lib --enable-ftp --with-servlet=/usr/local/JSDK2.0 --with-openssl=/vol/stage --with-gnu-ld --with-java=/usr/local/java --with-png-dir --with-tiff-dir --prefix=/vol/stage/apache --with-zlib

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-21 11:15 UTC] yohgaki@php.net
You cannot specify 2 SAPIs, apache and servlet.

BTW, if this typo?

--with-axs=/vol/stage/apache/bin/apxs 

should be

--with-apxs=/vol/stage/apache/bin/apxs 

If you properly configure/compile Apache/ModSSL, CFLASG=-DEAPI is not needed.


 [2002-01-21 11:53 UTC] ams at izoard dot com
I have rebuilt using the configure with the following paramewters and still get the same error

./configure  --with-mysql --with-apxs=/vol/stage/apache/bin/apxs --with-imap --with-libjpeg=/usr/local/lib --enable-ftp --with-openssl=/vol/stage --with-gnu-ld --with-java=/usr/local/java --with-png-dir --with-tiff-dir --prefix=/vol/stage/apache --with-zlib


Re apxs, it wasn't a typo yet the configure script didn't complain. Thanks for catching it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 08:01:23 2020 UTC