php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1510 -R options needed for linking -lttf and -lpq
Submitted: 1999-06-08 10:36 UTC Modified: 1999-07-17 12:03 UTC
From: veit at nexen dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0.9 OS: Solaris 2.5.1
Private report: No CVE-ID: None
 [1999-06-08 10:36 UTC] veit at nexen dot com
I had to modify configure so that -R options were passed to the linker for the ttf and pq libraries. Otherwise, when apache dynamically loaded the mod_php.so it would get unable to find library errors. Here are the changes I made to the configure file to get this to work for me:

Change (second occurrence of)

  LIBS="-lttf $LIBS"

to

  TTF_LIBDIR=/opt/gnu/lib
  TTF_LIB = -lttf
  if test -n "$APXS"; then
      TTF_LFLAGS="-L$TTF_LIBDIR ${apxs_runpath_switch}$TTF_LIBDIR'"
  else
      TTF_LFLAGS="-L$TTF_LIBDIR ${ld_runpath_switch}$TTF_LIBDIR"
  fi
  LIBS="$TTF_LFLAGS $TTF_LIB $LIBS"


Change

    PGSQL_LFLAGS=-L$PGSQL_LIBDIR

to

    if test -n "$APXS"; then
        PGSQL_LFLAGS="-L$PGSQL_LIBDIR ${apxs_runpath_switch}$PGSQL_LIBDIR'"
    else
        PGSQL_LFLAGS="-L$PGSQL_LIBDIR ${ld_runpath_switch}$PGSQL_LIBDIR"
    fi


I ran configure with the following options:

setenv CC cc
setenv CPPFLAGS -I/opt/gnu/include
setenv ORACLE_HOME /opt/oracle
./configure --prefix=/opt/gnu \
            --with-apxs=/opt/apache/apache_1.3.6/bin/apxs \
            --with-config-file-path=/opt/apache/apache_1.3.6 \
            --with-pgsql=/opt/postgresql --with-oracle

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-06-09 10:57 UTC] paul at cvs dot php dot net
Duplicate of #1518
 [1999-07-17 12:03 UTC] sas at cvs dot php dot net
fixed some time ago
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 22:03:37 2022 UTC