php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14962 unable to load extension php_sablot.dll
Submitted: 2002-01-10 06:33 UTC Modified: 2002-01-11 07:02 UTC
From: reckert at informationsgesellschaft dot com Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.1.1 OS: Windows 2000
Private report: No CVE-ID:
 [2002-01-10 06:33 UTC] reckert at informationsgesellschaft dot com
Extension php_sablot.dll can not be loaded (ISAPI-Version under IIS5). 
Microsofts Dependency Walker (depends.exe) reports a missing exported function in php4ts.dll.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-10 07:00 UTC] mfischer@php.net
And which?
 [2002-01-10 07:22 UTC] reckert at informationsgesellschaft dot com
Sorry, I haven't used the Dependency Walker much before. I guess the missing functions are
- zend_list_addref,
- zend_list_delete and
- wrong_param_count.
At least, these are marked red.
The full error message of the Dependency Walker is:
Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.

 [2002-01-10 07:32 UTC] hholzgra@php.net
guess you are using a dll from an older php version,
as the sablot extension has been replaced by the 
more general xslt extension since 4.1.0 ...?
 [2002-01-11 07:02 UTC] reckert at informationsgesellschaft dot com
Correct: I still used the php_sablot.dll instead of the new php_xslt.dll. Thanks.

I was misleaded by the fact that in the list of extensions in php.ini-recommended, php_sablot.dll was still listed.
 [2002-01-12 04:17 UTC] thepascha at gmx dot ch
This bug doesn't only exist with WIN200 and IIS5. I had the same bug with Windows ME and Apache 1.3.20.

But now, it works. 
Thanks.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 05:03:21 2014 UTC