php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14877 HTTP_FDF_DATA not available (php_fdf.dll crashes)
Submitted: 2002-01-05 17:24 UTC Modified: 2003-08-20 21:02 UTC
Votes:37
Avg. Score:4.4 ± 1.1
Reproduced:36 of 36 (100.0%)
Same Version:25 (69.4%)
Same OS:27 (75.0%)
From: cg at gordimer dot net Assigned: hholzgra (profile)
Status: Closed Package: FDF related
PHP Version: 4.3.3 dev 2003-05-31 OS: XP Pro
Private report: No CVE-ID: None
 [2002-01-05 17:24 UTC] cg at gordimer dot net
The data from a PDF form doesn't arrive at the php script when submitted in FDF format, however it works, when the same data is submitted by the form with POST.

I searched the data with phpinfo() to debug, but there were no entries (register_globals on and off). I tried with Apache 1.3.22 and IIS 5.1, submitting from Mozilla 0.97 and IE 6.

The same script works with a php 4.08dev from July, 3.

Test scripts and PDF form available on request.

Christoph

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-05 20:31 UTC] hholzgra@php.net
just curious: you have configured php to use the fdf extension?
 [2002-01-06 07:16 UTC] christoph dot grottolo at gmx dot net
yes, fdf is enabled.

I found out that I can get HTTP_FDF_DATA in PHP when I append #FDF to the destination URL of the form (in Acrobat). I can then write the fdf file and reopen it correctly using Acrobat.

But when trying to open it with php I always get th e following error:
Warning: Could not open fdf document: formtest.fdf in f:\testroot\formtest\formtest.php on line 7

I doublechecked the script, it's just the same as in the manual. I can open the fdf file with fopen, but not with fdf_open.

Could it be a version problem? I'm using Acrobat 5.05 which seems to produce FDF 1.2. I noticed that the fdfTk used in PHP is 4, the actual version from Adobe is 5.

Christoph
 [2002-10-21 15:28 UTC] hholzgra@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip

i've just updated fdf stuff to use fdftk 5.0
and some of its new features, maybe this also
solved your problem?
 [2002-10-23 14:12 UTC] christoph dot grottolo at gmx dot net
Now, php_fdf.dll crashes php when loaded at startup, even if there is no fdf data sent with the request. Without fdf, PHP works well. Do you need more info?
 [2002-10-28 10:43 UTC] sterling@php.net
Try erasing all old versions/files, then re-test...
 [2002-10-29 13:36 UTC] christoph dot grottolo at gmx dot net
I did so with snaps from today, same error. If you can use a .mdmp-File (MS-Dump) I can send it.

No other extensions loaded, php -i (CLI) at the command line quits with the same error as long as php_fdf.dll is enabled.
 [2002-10-29 17:06 UTC] sniper@php.net
What was the version of PHP with which it didn't crash?

 [2002-10-30 15:48 UTC] christoph dot grottolo at gmx dot net
The last one that I tried and that worked was 4.07dev from July,3 2001. Then a dev version from beginning of January 2002 was not working with other symptoms (see original bug report).
I then only tried again recently when Hartmut asked me to do so.
Meanwhile other people were mailing and asked me if I found a solution as they've had the same problems.
 [2002-11-03 11:15 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-11-29 14:01 UTC] christoph dot grottolo at gmx dot net
sorry for the delay - dev snapshot from today still crashing at startup when fdf is enabled.
 [2002-12-02 01:25 UTC] philip@php.net
I've been testing windows today (I have very little experience installing on win32 so bare with me) and so I decided to include all the dlls.  This particular one (php_fdf.dll) is causing problems and when the dll is loaded it gives an error at startup yet no error in the error log.  Apache still runs but PHP will not.

In short: I just experienced what Christoph did, *crash*.  Although I only tested php4.3.0rc2... Apache module.
 [2002-12-30 11:21 UTC] tnguyen at scpie dot com
Hi,

I installed the Win32 php 4.3.0 final released on a Windows NT server.  I created a phpinfo.php file to view the phpinfo and everything looks good.  The phpinfo.php file will not come up when I uncomment the php_fdf.dll extension.  Is there a fix for this?

Thanks,

Trent
 [2002-12-30 14:27 UTC] christoph dot grottolo at gmx dot net
I can confirm the bug (crash when php_fdf.dll is loaded) in 4.3.0 an current dev and stable snapshots.
 [2003-02-06 18:06 UTC] toni dot viemero at iki dot fi
We ran into this same bug today.

Windows (2000 and XP) with Apache 1.3.27 crashes (both 4.3.0 and todays win32 4.3.1-stable snapshot) when page is requested.

Apache 2.0.44 works ok on both platforms with php_fdf.dll and with both tested PHP versions.
 [2003-03-19 16:06 UTC] jharrell at dlc4me dot com
I'm getting the same crash with todays snapshot...[php4-win32-STABLE-200303191730] with php_fdf.dll uncommented I cannot get phpinfo() to do anything but crash. I sure hope this gets fixed soon... I moved to linux for a few months to continue with production, but my server runs php/Win2k... :(
 [2003-03-19 16:44 UTC] jharrell at dlc4me dot com
php_fdf.dll also crashes in: php5-win32-200303191930
 [2003-03-19 17:04 UTC] jharrell at dlc4me dot com
php_fdf.dll possibly works in:

php-4.2.3-Win32

(i have not scripted anything yet but... phpinfo() works...)
 [2003-03-19 17:50 UTC] jharrell at dlc4me dot com
fdftk ... php_fdf.dll works great in and so far only in (with regard to win32 only)... 4.2.3... saved me from creating my own fdf objects...

%FDF-1.2
%????
1 0 obj
<< 
/FDF << /Fields
 [2003-03-20 14:40 UTC] cg at gordimer dot net
Verified with old binaries: up to 4.07dev the extension works, in 4.1.x it does not, in 4.2.x it does again, in 4.3.x and in PHP5 it does not.

Would be cool to see a working extension in 4.3.x - because there will perhaps be a long time until a next stable version...
 [2003-03-24 05:43 UTC] rui dot gouveia at elementodigital dot pt
It's true it works with 4.2.3... but... 4.2.3 has another bug (see http://bugs.php.net/bug.php?id=20174) that prevents upload of big files!

I'm trapped... I need 4.2.3 to work with FDF... but I need higher than that to work with submission of big FDF?s?!?!?!

Somebody help?

Thanks
 [2003-04-30 10:14 UTC] charmaine dot richards at ngbailey dot co dot uk
I am trying to include php_fdf.dll in php 4.3.1 and I've also tried the latest snapshot for php 5 dev. As soon as the dll is enabled and fdftk.dll is added to c:\windows\system32 it produces a php.exe app error and a cgi error by not returning a complete set of HTTP headers.

I have tried removing everything and starting over with the zip file but no joy. 
The php.ini is in c:\windows and has been edited with cgi.force_redirect = 0, cgi_redirect_status_env = ENV_VAR_NAME and extension_dir = c:\php\extensions

php_pdf.dll works fine and phpinfo() returns with config path c:\windows\php.ini but once php_fdf.dll is enabled phpinfo() throws the error popup as mentioned.

I am running this on XP Pro with .NET framework and IE.6.
 [2003-05-09 14:44 UTC] cg at gordimer dot net
It now crashes no more at startup, but at quite every function call, e.g. fdf_set_value(), fdf_set_file().

Christoph
 [2003-05-14 17:09 UTC] cg at gordimer dot net
still the same after the last commits (no more crash at startup, but crash after function calls).
 [2003-05-28 04:51 UTC] hholzgra@php.net
ZTS crashes fixed (this time the cause, not just a symptom)

... now testing the original HTTP_FDF_DATA problem ...
 [2003-05-30 20:22 UTC] jharrell at dlc4me dot com
Can I use the new release...? Or will it still crash? I don't feel like spending my weekend "upgrading" and then "downgrading" a production unit... ;)
 [2003-05-31 04:24 UTC] stone@php.net
It's at least partly usable. As Hartmut said, there's still an issue with HTTP_FDF_DATA (FDF input) - I have not yet tested. However you can create and send FDF data without problems now (4.3.2. release).

 [2003-07-28 14:05 UTC] jharrell at dlc4me dot com
4.3.3RC1 does not load the fdf_tk module. It ignores the php.ini setting. 4.3.2 loads the module with the same .ini


jh
 [2003-08-20 21:02 UTC] sniper@php.net
Seems to be fixed in CVS. I can not reproduce any of the problems mentioned in this bug report.
(using the FDFTK.DLL from the distribution, and php.ini-dist as the php.ini, under Apache 2.0.47)

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Oct 18 13:01:25 2018 UTC