php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14758 $HTTP_GET_VARS Improper NAME scrambling
Submitted: 2001-12-29 22:34 UTC Modified: 2001-12-29 22:54 UTC
From: chris at chrisderose dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.6 OS: Linux 2.4 (Mandrake 6.1)
Private report: No CVE-ID: None
 [2001-12-29 22:34 UTC] chris at chrisderose dot com
<?	 if (!sizeof($HTTP_GET_VARS) ) { ?>
<FORM ACTION="<?=$PHP_SELF?>" METHOD="GET">
<INPUT TYPE="TEXT" NAME="Test Input" VALUE="doh!">
<INPUT TYPE="SUBMIT">
</FORM>
<?} else { ?>
This won't work (it should):<?=$HTTP_GET_VARS['Test Input']?><BR>
This will:<?=$HTTP_GET_VARS['Test_Input']?><BR>
<? } ?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-29 22:54 UTC] mfischer@php.net
Since spaces aren't allowed in variable names (obviously) they're converted to underscores. Bo bug -> bogus.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 13 07:01:34 2024 UTC