php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14746 Problem whith option --with-mnogosearch
Submitted: 2001-12-28 16:37 UTC Modified: 2002-07-07 19:52 UTC
From: pescobar at ns dot ulat dot ac dot pa Assigned:
Status: Not a bug Package: mnoGoSearch related
PHP Version: 4.1.1 OS: Red Hat 7.2
Private report: No CVE-ID: None
 [2001-12-28 16:37 UTC] pescobar at ns dot ulat dot ac dot pa
Hi...

I have a problem in configuration of php-4.0.6 and php-4.1.0 when I use the option --with-mnogosearch

PHP Configuration
./configure --with-pgsql=/usr/local/pgsql --enable-track-vars --disable-debug --with-apxs=/usr/local/apache/bin/apxs --enable-versioning --with-config-file-path=/usr/php4/lib --enable-libgcc --with-imap=/usr/local/lib --enable-ftp  --with-mysql --with-kerberos --with-sybase-ct=/opt/sybase-11.9.2 --with-openssl=../openssl-0.9.6b/ --with-mnogosearch
------------------------------------------------------

/bin/sh /root/php-4.1.0/libtool --silent --mode=compile gcc  -I. -I/root/php-4.1.0/main -I/root/php-4.1.0/main -I/root/php-4.1.0 -I/usr/local/apache/include -I/root/php-4.1.0/Zend -I/root/openssl-0.9.6b/include -I/usr/include/imap -I/usr/local/mnogosearch/include -I/root/php-4.1.0/ext/mysql/libmysql -I/opt/sybase-11.9.2/include -I/root/php-4.1.0/ext/xml/expat  -DLINUX=22 -DMOD_SSL=208104 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I/root/php-4.1.0/TSRM -g -O2 -prefer-pic  -c internal_functions.c
In file included from /usr/local/mnogosearch/include/udmsearch.h:37,
                 from /root/php-4.1.0/ext/mnogosearch/php_mnogo.h:31,
                 from internal_functions.c:34:
/usr/local/mnogosearch/include/udm_doc.h:7: parse error before `1'
make[2]: *** [internal_functions.lo] Error 1
make[2]: Leaving directory `/root/php-4.1.0/main'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/php-4.1.0/main'
make: *** [all-recursive] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-28 19:30 UTC] mrobinso@php.net
What version of mnogosearch are you using?

The current stable version of mnogosearch compiles
fine (mnoGoSearch-3.1.19).

 [2002-01-19 11:26 UTC] sander@php.net
No feedback. Closing.
 [2002-02-16 08:58 UTC] nohn@php.net
The PHP 4.1.0 and 4.1.1-Versions don't support mnoGoSearch 3.2.x. The solution is either to use a CVS-Snapshot of PHP, or if you don't like CVS snaphots, at least to update ext/mnogosearch this way:

- rm ext/mnogosearch
- download and extract PHP extension module vwrsion 1.49 from www.mnogosearch.ru
- ./buildconf in the main sourcetree
- your configure, make, make install should work normal... at least it would'nt fail with mnogosearch.


 [2002-07-07 19:52 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 16:01:27 2021 UTC