php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14724 imagecreatetruecolor() and imagecopyresampled()
Submitted: 2001-12-27 15:29 UTC Modified: 2002-03-25 13:40 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:3 (100.0%)
From: waldo at monster dot vg Assigned:
Status: Closed Package: GD related
PHP Version: 4.1.0 OS: Windows 2000
Private report: No CVE-ID: None
 [2001-12-27 15:29 UTC] waldo at monster dot vg
I get the following error with PHP 4.10 and some GD functions:
Fatal error: imagecreatetruecolor(): requires GD 2.0 or later in ?..
Fatal error: imagecopyresampled(): requires GD 2.0 or later in ?..
imagecreate() and imagecopyresized() are working correct.
The same code worked fine with PHP 4.06.

Is this a bug or are the functions imagecreatetruecolor() and imagecopyresampled() renamed?

Thanks,

Waldo Monster

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-27 15:31 UTC] mfischer@php.net
Unfortunately it was decided to support gd2.0 with the 4.1.0 binaries. I hope the one in charge changes this with the 4.1.1 release.
 [2001-12-27 15:32 UTC] mfischer@php.net
Bla. "... was decided to NOT support gd2.0 ..."
 [2002-03-17 11:50 UTC] sander@php.net
Hopefully this will be OK in 4.2.0. Anyway, the packager probably doesn't look at the bugdb so let's close this one.
 [2002-03-25 13:40 UTC] waldo at monster dot vg
Thanks for the info.
With the new extension php_gd.dll form PHP 4.2.0 RC1 everything is working correct :-)

Waldo Monster
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 04:05:54 2022 UTC