php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14625 socket servers expect more data from PHPCGI
Submitted: 2001-12-20 11:23 UTC Modified: 2002-06-11 09:57 UTC
From: wolfgang dot sprick at tlc dot de Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.1.0 OS: Windows 2000
Private report: No CVE-ID: None
 [2001-12-20 11:23 UTC] wolfgang dot sprick at tlc dot de
Standard sequence of single fsockopen, fputs, fgets, fclose "hangs" servers.

Our own C++-servers and several samples of socket-servers we found in the Internet work with other clients, but when being used by PHP scripts in the standard way described all around try to recv(eive) more data from the PHP script, that itself waits at the fgets statement. Finally this locking situation is resolved by some timer running up at client or server side.

Data sent by PHP script is received by the servers in the correct length and echo servers or others do send data back before going back to the recv the actually hangs the (non-blocking server or thread).

So from PHP side some information like "end of transmission" seems to be missing at the server side.

Same behavior using PHP 4.0.6




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-02 13:05 UTC] wolfgang dot sprick at tlc dot de
Has been replaced by a more specific bug report showing other problems.
 [2002-06-11 09:57 UTC] sniper@php.net
Closing this as there's no indication to which bug this is duplicate.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 09:01:25 2020 UTC