php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14610 configure script looks in the wrong place for httpd.h
Submitted: 2001-12-19 18:20 UTC Modified: 2001-12-20 07:22 UTC
From: aaron at bigmouse dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.1.0 OS: Linux
Private report: No CVE-ID: None
 [2001-12-19 18:20 UTC] aaron at bigmouse dot net
I'm trying to configure php 4.1.0 on my server running turbolinux 6.0 with Apache 2.0.28

By default Apache 2.0.x installs to /usr/local/apache2

php 4.1.0 configure --with-apache defaults to /usr/include/apache

no biggy, I do configure --with-apache=/usr/local/apache2
but it still can't find httpd.h

I have a look at configure and it's looking for httpd.h like this 
    # For Apache 2.0.x
    elif test -f $withval/src/include/httpd.h &&
Which doesn't exist because httpd.h is in /usr/local/apache2/include/

I know perl pretty good, but I don't have a lot of experience with regular old shell scripting.

I've done a little hacking of the configure script to correct this, but it's still not working right as I've most likely missed something of did something wrong in my hacking.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-20 07:22 UTC] sander@php.net
If you want to compile PHP as a static module (that's what you're trying) you should point PHP to the source of Apache, not to the installation dir.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 15:03:33 2021 UTC