php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #14561 strtotime() bug
Submitted: 2001-12-17 10:57 UTC Modified: 2005-06-28 23:11 UTC
From: wachters at iae dot nl Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 4.0.6 OS: Linux ?.?
Private report: No CVE-ID:
 [2001-12-17 10:57 UTC] wachters at iae dot nl
strtotime("19:30 Dec 17"); // works okay
strtotime("Dec 17 19:30"); // returns -1

that's a bug i think. strangely enough the bug wasn't there in Php 4.0.5.. only in 4.0.6
gtx Bucky

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-18 07:12 UTC] sander@php.net
Can you try the latest CVS? There are some bugs fixed related to strtotime.
 [2001-12-18 07:15 UTC] derick@php.net
I could reproduce this with 4.1.0 and 4.2.0dev, it's not fixed.
But it's not a bug either, as strtotime does not understand every date syntax.
Making this s feature request.

Derick
 [2001-12-22 15:48 UTC] sander@php.net
You should better practice your type-changing skills ;)
 [2005-06-28 23:11 UTC] nlopess@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Fixed in 5.1.0
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 19:01:53 2014 UTC