php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14558 not worked ibase_connection(..)
Submitted: 2001-12-17 08:34 UTC Modified: 2002-04-04 07:45 UTC
Votes:4
Avg. Score:4.5 ± 0.5
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:3 (75.0%)
From: anton_bl at chat dot ru Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.1.0 OS: win xp,2000,98
Private report: No CVE-ID:
 [2001-12-17 08:34 UTC] anton_bl at chat dot ru
interbase

ibase_connect(...) - is not worked - has crashed php.exe in  next operation at open database

version php 4.1.0, 4.0.6 - error
4.0.5 - correctly worked 

if you change ibase_connect(...) -> ibase_pconnect(...)
all worked correctly/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-18 07:13 UTC] dbadmin at avenet dot stw dot uni-erlangen dot de
I can confirm this bug! Appears under Debian Linux too.

One curious example:

a simple php-script that reads all records of a db-table and echo's them works fine with e.g. table a,b and c. when I trie it with e.g. table d and e, PHP crashes with a segmentation fault in the apache-error-log.

I used the following script:

###########################################################
<html>
<head>
<title>PHP/InterBase test</title>
</head>
<body>
<?
$conn=ibase_pconnect ("localhost:/path/to/db-file.gdb", "user", "password");
   if (!$conn) 
   {
    	echo "Acess Denied!<br>";
        exit;
   }

   $result=ibase_query($conn, "select * from any_table");
   if (!$result)
   {
   	echo "<br>Error executing query select count!";
    	exit;
   }

    while ($row=ibase_fetch_row ($result)) {
    	echo $row[0] . "<br>";
    }

    ibase_close($conn);
?>
</body>
</html>



It happens only with ibase_connect after the execution of the following ibase-function. ibase_pconnect seems to work fine.

If more info is needed, feel free to contact me via email.
 [2002-02-18 07:36 UTC] dbadmin at avenet dot stw dot uni-erlangen dot de
here some more info:

tried the above described situation with PHP 4.0.6 -> works fine. 

will now have a look at php-source changes in the interbase modul between version PHP 4.0.6 and PHP 4.1.1...
 [2002-02-18 08:32 UTC] dbadmin at avenet dot stw dot uni-erlangen dot de
does not seem to be a problem with the interbase-module code, compiling and using PHP 4.1.1 with interbase-module-code of PHP 4.0.6 results in the same error described above!
 [2002-02-18 10:57 UTC] dbadmin at avenet dot stw dot uni-erlangen dot de
finally tried it with PHP 4.2.0-dev fresh out of CVS, but did not help. ibase_connect crashes PHP with seg.fault - not always, but quite often.
 [2002-04-04 03:37 UTC] daniela@php.net
Should be fixed in today CVS (4.3.0-dev)

same as bug #1549 - #15992

you'll find an example about how to use ibase_close() at:
http://www.php.net/manual/en/function.ibase-close.php
 [2002-04-04 07:00 UTC] sniper@php.net
fixed -> closed
 [2002-04-04 07:45 UTC] daniela@php.net
sorry for wrong bug number report  ...
same as bug: #15419 and  #14558
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 08:02:55 2014 UTC