|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14555 apache fails: undefined symbol: XML_SetParamEntityParsing
Submitted: 2001-12-16 22:02 UTC Modified: 2001-12-31 10:38 UTC
From: php at sauen dot com Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.1.0 OS: debian woody
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: php at sauen dot com
New email:
PHP Version: OS:


 [2001-12-16 22:02 UTC] php at sauen dot com
Config, compile and install works fine, apache fails to start:
Apache: Starting Syntax error on line 226 of /usr/local/conf/httpd.conf:
Cannot load /usr/local/libexec/ into server: /usr/local/lib/ undefined symbol: XML_SetParamEntityParsing
/usr/local/bin/apachectl start: httpd could not be started

./configure \
  --with-apxs  \
  --with-mysql \
  --with-zlib  \
  --with-bz2   \
  --with-curl  \
  --with-dom   \
  --enable-ftp \
  --with-gd    \
  --enable-gd-native-ttf  \
  --with-gmp   \
  --enable-sockets \
  --with-openssl   \
  --with-ldap      \
  --enable-xslt    \
  --with-xslt-sablot \

apache 1.3.22
sablot 0.71
expat 1.95.2
libxml 2.4.10
xmltok 1.1

Apache and PHP was compiled and installed manually, the rest has been done with .deb packages/apt.

In order to successfully compile, configure didnt stop, had to install dev-files for xmltok, libxml and sasl (used deb's)


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-17 02:44 UTC]
What does the output of

  strings /usr/local/lib/|grep XML_SetParamEntityParsing

gives you?

If you're missing the symbol your libsablot installation is broken.

 [2001-12-17 17:54 UTC] php at sauen dot com
That gives one line with "XML_SetParamEntityParsing", so I assume it is in there. There was no probs compiling and installing Sablot, I have NOT found any similar issue on the gingerall pages or any other mailing lists/newsgroups I've searched.
 [2001-12-17 17:57 UTC]
Please post the output of this:

nm /usr/local/lib/ | grep XML_SetParamEntityParsing
 [2001-12-17 22:33 UTC] php at sauen dot com
balder:~# nm /usr/local/lib/ | grep XML_SetParamEntityParsing
         U XML_SetParamEntityParsing

Unlinked I guess, I don't really know what it means in this context, maybe something I should investigate with gingerall/sablot lists.
 [2001-12-31 10:38 UTC]
Not a PHP bug.
 [2002-01-17 02:47 UTC] lehel at freemail dot hu
Same for me: PHP 4.0.6
tried: Sablot 0.52 0.65 0.70 0.71 0.80
on: Mandrake 8.1, Debian 2.2r4 upgraded to sid
All of them generates the same error, when I compiled the module sablot (phpize ./configure --with-sablot=shared make all, copying the to libdir, and adding to php.ini. On debian it segfaults, on Mandrake generates the described error message in the apache error log).
On older system (mandrake 7.2 krnel 2.2.19 glibc 2.1.3 no problems)
when compiling with --enable-xslt --with-xslt-sablot
the script fails during make claiming duplicate function declarations in sablot.c
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 21 20:01:24 2021 UTC