php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14504 core dump in session handling
Submitted: 2001-12-14 01:28 UTC Modified: 2002-01-05 16:49 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mattias dot nilsson at ballou dot se Assigned:
Status: Closed Package: Apache related
PHP Version: 4.1.0 OS: FreeBSD 4.2-RELEASE
Private report: No CVE-ID: None
 [2001-12-14 01:28 UTC] mattias dot nilsson at ballou dot se
PHP config:
./configure  --with-mysql=/app/mysql --with-apache=../apache_1.3.22/ --enable-
track-vars --with-jpeg-dir=/usr/local/ --enable-inline-optimization --with-png-dir=/usr/local --with-zlib --with-zlib-dir=/usr/lib/ --with-openssl --with-freetype-dir=/usr/local/ --with-gd=/usr/local --enable-gd-native-tt --enable-gd-imgstrttf --enable-gd-native-ttf --enable-shmop --enable-sysvsem --enable-sysvshm --with-imap=/usr/local/


GDB Backtrace:
gdb /app/apache/bin/httpd
GNU gdb 4.18
This GDB was configured as "i386-unknown-freebsd"...
(gdb) run -X
Starting program: /app/apache/bin/httpd -X

Program received signal SIGSEGV, Segmentation fault.
0x81281d5 in zend_hash_del_key_or_index (ht=0x73755f72,
    arKey=0x83746ec "verified_user", nKeyLength=14, h=0, flag=0)
    at zend_hash.c:482
482             nIndex = h & ht->nTableMask;
(gdb) where
#0  0x81281d5 in zend_hash_del_key_or_index (ht=0x73755f72,
    arKey=0x83746ec "verified_user", nKeyLength=14, h=0, flag=0)
    at zend_hash.c:482
#1  0x80c17f8 in zif_session_unregister (ht=1, return_value=0x83746cc,
    this_ptr=0x0, return_value_used=0) at session.c:1201
#2  0x81426b1 in execute (op_array=0x8359400) at ./zend_execute.c:1590
#3  0x8142850 in execute (op_array=0x832960c) at ./zend_execute.c:1630
#4  0x8146a04 in execute (op_array=0x832928c) at ./zend_execute.c:2133
#5  0x8146a04 in execute (op_array=0x82f7a8c) at ./zend_execute.c:2133
#6  0x8124a28 in zend_execute_scripts (type=8, retval=0x0, file_count=3)
    at zend.c:814
#7  0x808f682 in php_execute_script (primary_file=0xbfbff8e4) at main.c:1309
#8  0x812cc26 in apache_php_module_main (r=0x830a034, display_source_mode=0)
    at sapi_apache.c:90
#9  0x808caf2 in send_php ()
#10 0x808cb46 in send_parsed_php ()
#11 0x814e10d in ap_invoke_handler ()
#12 0x8162a44 in process_request_internal ()
#13 0x8162aae in ap_process_request ()
#14 0x8159a1b in child_main ()
#15 0x8159bdd in make_child ()
#16 0x8159d56 in startup_children ()
#17 0x815a388 in standalone_main ()
#18 0x815abd8 in main ()
#19 0x806c4c1 in _start ()

This occurs seemingly at random and quite frequently. I will try and create a small script to reproduce the problem. This might be caused by unregistering a non-registered variable in the session.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-14 03:34 UTC] yohgaki@php.net
Yet another segfault problem with FreeBSD & Session.....

Any freebsd hackers around?
I think this can be a FreeBSD's problem.
(A user reported SIGBUS, there should be something
really wrong... He is getting SIGBUS and SIGSEGV.
Bug# 14497)


Are you getting SIGBUS?
Check your apache log and report how you've got, please.
 [2002-01-05 16:49 UTC] lobbin@php.net
No feedback. Closing.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 15:01:29 2024 UTC