|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14452 is not linking with *.la files
Submitted: 2001-12-12 07:47 UTC Modified: 2002-07-19 01:00 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: glen at designsolution dot co dot uk Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.2.1 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2001-12-12 07:47 UTC] glen at designsolution dot co dot uk
I have configured PHP with the following options:

./configure --with-apxs=/usr/sbin/apxs --with-mysql=/usr

/usr/lib/mysql contains libmyclient.a and  
Configuration and make goes fine, though I get the 
following warning:

*** Warning: This library needs some functionality provided 
by /usr/lib/mysql/
*** I have the capability to make that library 
automatically link in when
*** you link to this library.  But I can only do this if 
you have a
*** shared version of the library, which you do not appear 
to have.

Install goes fine, but when I restart Apache ( 1.3.3 ), I 
get the following error:

Cannot load /usr/lib/apache/ into server: /usr/
lib/apache/ undefined symbol: mysql_free_result

PHP 4.0.6 compiled from source and ran with no such 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-12 12:45 UTC]
I guess you're getting the libtool bug I noticed myself too.
Try deleting the .la file.

 [2001-12-13 06:18 UTC] glen at designsolution dot co dot uk
I deleted the file from /usr/lib/mysql 
and tried re-compiling, but still got the same error.
 [2001-12-13 23:55 UTC]
How exactly did you configure/compile/install Mysql ?
And what linux distribution is this ?


 [2001-12-14 04:14 UTC] glen at designsolution dot co dot uk
MySQL was installed from RPM's a while ago:


The system is a Cobalt Qube 2:

Linux qube.dessol 2.0.34C51_SK #1 Mon Nov 29 07:59:59 CET 
1999 mips unknown

By the way, I also tried linking with libmcal.a which is 
installed in /usr/local/mcal/lib/.  I used the 
configuration option --with-mcal=/usr/local/mcal and 
configuration/compiling/installing went fine.  However, 
when restarting Apache, I get:

Cannot load /usr/lib/apache/ into server: /usr/
lib/apache/ undefined symbol: mcal_close

I don't know what's going on here, but it seems the *.a 
files are not being linked to correctly?  There was no such 
problems with the 4.0.6 release which I compilied with 
MySQL and MCAL support with no problems.


 [2002-01-02 11:30 UTC] glen at designsolution dot co dot uk
I have sucessfully linked PHP4.1.1 to static libtool 
libraries with the following method:

1. ./configure in the 4.0.6 source directory
2. ./configure in the 4.1.1 source directory
3. copy the libtool from 4.0.6 to the 4.1.1 direcory
4. make
5. make install

Obviously this is a little messy, but it does seem to work 



 [2002-06-06 20:51 UTC]
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

 [2002-06-07 04:14 UTC] glen at designsolution dot co dot uk
Still not working with 4.2.1.  This is particurlarly 
problematic with MCAL which only compiles as a static 
 [2002-06-07 07:35 UTC]
Please give more information what the actual problem is.
Is the problem only with '--with-mcal' ??

 [2002-06-07 12:03 UTC] glen at designsolution dot co dot uk
As I have mentioned above, PHP does not seem to compile 
correctly with static libtool libraries.  I have static 
MySQL and MCAL libraries, and PHP fails to link to either.  
PHP 4.0.6 worked, but nothing since has.
 [2002-06-07 13:37 UTC]
This must be some mips related thing since it works 
fine for me and many others. And hard to fix/debug as
I think none of the developers have access to such system.

Do you get any clear compile _errors_ ?
Does config.log have any clues?


 [2002-06-18 07:53 UTC] glen at designsolution dot co dot uk
There are no compile errors at all.  Everything goes well until I start Apache.  Then I get errors about missing MySQL or MCAL functions.

PHP 4.0.6 was the last version that worked correctly.
 [2002-06-18 17:20 UTC]
Still guessing here..but it might be another of those
autoconf problems we've seen. Please try this snapshot:

 [2002-07-19 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jun 23 11:01:30 2024 UTC