php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #14447 Thread Safe extension list
Submitted: 2001-12-12 02:19 UTC Modified: 2013-10-05 07:31 UTC
Votes:21
Avg. Score:4.2 ± 1.1
Reproduced:15 of 16 (93.8%)
Same Version:8 (53.3%)
Same OS:9 (60.0%)
From: edejanu at route66 dot ro Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.1.0 OS: ALL
Private report: No CVE-ID: None
 [2001-12-12 02:19 UTC] edejanu at route66 dot ro
Will be nice if the documentation will list for each
function category all the functions that are thread safe
or not.
Ex:
XVI. Date and Time functions

time function is not thread safe

Mabe be a new node in the manual
like the "Function Reference" node.


What you say about this?

Best regards, 

Emanuel Dejanu

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-02 18:33 UTC] nicos@php.net
It would be nice, it's up the maintainer that does the documentation to give such informations. Anyway I change it's status to a feature request. 

Maybe Goba or Philip will have a nice idea for that?
 [2010-12-17 14:11 UTC] jani@php.net
-Summary: Thread Safe +Summary: Thread Safe extension list -Package: Feature/Change Request +Package: Documentation problem
 [2013-10-05 07:31 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2013-10-05 07:31 UTC] krakjoe@php.net
An inclusive list is not required; the vast majority of PHP and the libraries it interacts with are, nowadays, thread safe. The exceptions are noted.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Apr 06 12:01:25 2020 UTC