php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14440 Wrong calculation of timestamp
Submitted: 2001-12-11 18:40 UTC Modified: 2001-12-13 07:19 UTC
From: clemens at gutweiler dot net Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.1.0 OS: Linux 2.4.16
Private report: No CVE-ID: None
 [2001-12-11 18:40 UTC] clemens at gutweiler dot net
strtotime() returns an wrong timestamp from the date-string:

echo date( 'd.m.Y H:i:s', strtotime( 'Tue, 11 Dec 2001 23:38:06 +0100' ) );

return "07.12.2001 20:38:06" under 4.1.0.., 
4.0.6 return "11.12.2001 23:38:06"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-11 19:26 UTC] cg@php.net
Assigned Type
 [2001-12-11 19:27 UTC] cg@php.net
too late ;)
 [2001-12-12 02:41 UTC] derick@php.net
I can reproduce this with php 4.1.0, but not with php 4.2.0 (Dev version). Can you verify that by using a snapshot from snaps.php.net?

Derick
 [2001-12-12 03:06 UTC] clemens at gutweiler dot net
It's the stable 4.1.0 Release, not an Dev-Version

Clemens
 [2001-12-12 11:42 UTC] sniper@php.net
Can't reproduce with latest CVS. Fixed -> closed.

 [2001-12-13 07:19 UTC] derick@php.net
It's now fixed in the 4.1.0 branch, it may be included in a 4.1.1 release.

Derick
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 29 03:03:49 2022 UTC