php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14386 function p/connect do not work in FreeBSD
Submitted: 2001-12-08 15:23 UTC Modified: 2001-12-11 03:28 UTC
From: matlab21 at yahoo dot es Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 4.0.6 OS: FreeBSD
Private report: No CVE-ID: None
 [2001-12-08 15:23 UTC] matlab21 at yahoo dot es
Hello everybody.

I am using FreeBSD+Apache+PHP+Postgres.
By now, I'm using the newest versions:

- FreeBSD 4.4
- Apache_1.3.22
- PHP-4.0.6 ( I have proved the 4.1RC3 and have the same problem)
- Postgresql-7.1.3

I use the same three last components in Linux ans SunOS and I have not any problems. I always try to compile from source, I always make the same instructions and in FreeBSD PHP can not connect with PostgreSQL.
I install everything with:

tar xvzf postgresql-7.1.3.tar.ga
cd postgresql-7.1.3
./configure && make && make install
initdb -D /usr/local/pgsql/data
postmaster -i -D /usr/local/pgsql/data &

Now postgres is running.

tar xvzf apache_1.3.22.tar.gz
cd apache_1.3.22
./configure 
cd ..
tar xvzf php-4.0.6.tar.gz
cd php-4.0.6
./configure --with-pgsql=/usr/local/pgsql/ --without-mysql --with-apache=../apache_1.3.22 --enable-track-vars
make 
make install

cd ../apache_1.3.22
./configure --enable-module=src/modules/php4/libphp4.a
make 
make install

Edit /usr/local/apache/conf/httpd.conf to make use of PHP

Start apache
/usr/local/apache/bin/apachectl start

In this moment I have apache listening in port 80 and postgres in 5432 ( i know this using ps-e  and nmap localhost).

In this moment apache works, PHP works. I can see the simple script <?php phpinfo(); ?> with no problems.
But I can not connect to PostgreSQL database ( tried connect and pconnect functions). After a while apperas this message:


Warning: Unable to connect to PostgreSQL server: connectDBStart() -- connect() failed: No route to host Is the postmaster running (with -i) at 'localhost' and accepting connections on TCP/IP port 5432? in /usr/home/pfc/phplib/php/db_pgsql.inc on line 47
Database error: Link-ID == false, pconnect failed
PostgreSQL Error: 0 ()
Session halted.

I can sure you that postgres is running and I iniciate postmaster with the '-i' flag. In the file /usr/local/pgsql/data/pg_dba.conf I have the following:

local  all           trust
host all 127.0.0.1 255.255.255.0 trust
host all 192.168.99.1 255.255.255.0 trust

NOTE: 192.168.99.1 is the server's IP.

I can sure I have installed apache-php-postgres in linux and SunOS with the same method and here work well. I do not know why PHP can not comunicate with PostgreSQL using FreeBSD.

Thanks a lot for.

I am pleased if anyone could solvent this problem.
If there is anyone who want contact me (for telling more details, ... ) no doubt write to: matlab21@yahoo.es

Xevi Serrats.

NOTE: excuse me, english isn't my native language.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-11 03:28 UTC] cardinal@php.net
Not a bug.  Please send support questions to an appropriate
mailing list such as php-general or php-db.

http://php.net/support.php
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 01:01:28 2019 UTC