php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14379 Pb while using php in command line...
Submitted: 2001-12-07 09:03 UTC Modified: 2001-12-11 13:50 UTC
From: shuber at fmlogistic dot fr Assigned:
Status: Not a bug Package: Sybase-ct (ctlib) related
PHP Version: 4.0.6 OS: Linux RedHat 7.0
Private report: No CVE-ID: None
 [2001-12-07 09:03 UTC] shuber at fmlogistic dot fr
Well, i've successfully compiled PHP 4.0.6 as a static and dynamic module

i encounter a problem when running the static one:

1) beeing root i launch:
/usr/local/bin/php -v

-> right, answer is the following one :
4.0.6

2) beeing any other user i launch too:
/usr/local/bin/php -v

-> bad answer :
Instruction ill?gale (core dumped)

3) After modifying the command line to compile, i find out that if sybase_ct is disabled the command line works for everyone !


Here is the options i use to compile:
./configure --with-mysql --with-gd --with-sybase_ct=/opt/sybase-11.9.2/ --with-config-file-path=/etc/php_statique --with-ldap --with-imap --enable-ftp --with-oci8=/u01/app/oracle/product/8.1.7/

-> Yes, we use Sybase, Oracle & MySQL ;o)

Using GDB, i get:
alahaye@mercure ~>gdb "/usr/local/bin/php -v" core
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...unknown option `-v'

Core was generated by `/usr/local/bin/php -v'.
Program terminated with signal 4, Illegal instruction.
Reading symbols from /lib/libpam.so.0...done.
Loaded symbols for /lib/libpam.so.0
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /opt/sybase-11.9.2//lib/libinsck.so...done.
Loaded symbols for /opt/sybase-11.9.2//lib/libinsck.so
Reading symbols from /opt/sybase-11.9.2//lib/libsybtcl.so...done.
Loaded symbols for /opt/sybase-11.9.2//lib/libsybtcl.so
Reading symbols from /opt/sybase-11.9.2//lib/libintl.so...done.
Loaded symbols for /opt/sybase-11.9.2//lib/libintl.so
Reading symbols from /opt/sybase-11.9.2//lib/libcomn.so...done.
Loaded symbols for /opt/sybase-11.9.2//lib/libcomn.so
Reading symbols from /opt/sybase-11.9.2//lib/libct.so...done.
Loaded symbols for /opt/sybase-11.9.2//lib/libct.so
Reading symbols from /opt/sybase-11.9.2//lib/libcs.so...done.
Loaded symbols for /opt/sybase-11.9.2//lib/libcs.so
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /usr/lib/libldap.so.1...done.
Loaded symbols for /usr/lib/libldap.so.1
Reading symbols from /usr/lib/liblber.so.1...done.
Loaded symbols for /usr/lib/liblber.so.1
Reading symbols from /usr/lib/libgd.so.1.8...done.
Loaded symbols for /usr/lib/libgd.so.1.8
Reading symbols from /lib/libcrypt.so.1...done.
Loaded symbols for /lib/libcrypt.so.1
Reading symbols from /lib/libresolv.so.2...done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /lib/libnsl.so.1...done.
Loaded symbols for /lib/libnsl.so.1
Reading symbols from /u01/app/oracle/product/8.1.7//lib/libclntsh.so.8.0...done.
Loaded symbols for /u01/app/oracle/product/8.1.7//lib/libclntsh.so.8.0
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /usr/lib/libttf.so.2...done.
Loaded symbols for /usr/lib/libttf.so.2
Reading symbols from /usr/lib/libjpeg.so.62...done.
Loaded symbols for /usr/lib/libjpeg.so.62
Reading symbols from /usr/lib/libpng.so.2...done.
Loaded symbols for /usr/lib/libpng.so.2
Reading symbols from /usr/lib/libz.so.1...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /u01/app/oracle/product/8.1.7/lib/libwtc8.so...done.
Loaded symbols for /u01/app/oracle/product/8.1.7/lib/libwtc8.so
Reading symbols from /lib/libpthread.so.0...done.
rw_common (): write: Succ?s.

warning: unable to set global thread event mask
[New Thread 1024 (LWP 19079)]
rw_common (): write: Succ?s.

warning: stop_or_attach_thread: generic error
Loaded symbols for /lib/libpthread.so.0
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x408b1cf8 in main_arena () from /lib/libc.so.6
(gdb) bt
#0  0x408b1cf8 in main_arena () from /lib/libc.so.6
#1  0x407ebf1a in buffered_vfprintf (s=0x408b1c60, 
    format=0xbfffde14 "\n\nThe context allocation routine failed when it tried to load localization files!!\n", args=0x53)
    at vfprintf.c:2073
#2  0x407e712b in _IO_vfprintf (s=0x408b1c60, 
    format=0xbfffde14 "\n\nThe context allocation routine failed when it tried to load localization files!!\n", 
    ap=0xbfffd7c0) at vfprintf.c:1245
#3  0x407f0d47 in fprintf (stream=0x408b1c60, 
    format=0xbfffde14 "\n\nThe context allocation routine failed when it tried to load localization files!!\n")
    at fprintf.c:32
#4  0x4007b722 in com_perr () from /opt/sybase-11.9.2//lib/libcomn.so
#5  0x4006d3ed in com_intl_verify_ctxloc () from /opt/sybase-11.9.2//lib/libcomn.so
#6  0x401114a9 in cs_ctx_alloc () from /opt/sybase-11.9.2//lib/libcs.so
#7  0x80e007a in php_sybase_init_globals (sybase_globals=0x820a020) at php_sybase_ct.c:275
#8  0x80e0234 in php_minit_sybase (type=1, module_number=2) at php_sybase_ct.c:334
#9  0x80f7247 in zend_startup_module (module=0x81f5700) at zend_API.c:624
#10 0x806cdcf in php_startup_extensions (ptr=0x81ec3a0, count=12) at main.c:703
#11 0x806daae in php_startup_internal_extensions () at internal_functions.c:68
#12 0x806d119 in php_module_startup (sf=0x81eb5e0) at main.c:873
#13 0x806b91d in main (argc=2, argv=0xbffff964) at cgi_main.c:400
#14 0x407afb65 in __libc_start_main (main=0x806b874 <main>, argc=2, ubp_av=0xbffff964, init=0x8069c38 <_init>, 
    fini=0x817068c <_fini>, rtld_fini=0x4000df24 <_dl_fini>, stack_end=0xbffff95c) at ../sysdeps/generic/libc-start.c:111


Hope you'll find what's wrong with this


Best regards,
   Sebastien Huber - Linux admin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-11 13:50 UTC] derick@php.net
Looks like a bug in the sybase libraries. My guess is that it has to do with some environment variables not set.
Not a PHP bug > bogus
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 23:01:27 2019 UTC