php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14347 PHP 4.06 with Freetype 2 and GD 2 does not anti-alias
Submitted: 2001-12-05 06:41 UTC Modified: 2001-12-05 06:42 UTC
From: hs at cybertec dot at Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
 [2001-12-05 06:41 UTC] hs at cybertec dot at
PHP 4.06 with Freetype 2 and GD 2 does not anti-alias.
In the documentation it says that anti-aliasing can only be disabled by using a negative color (-$black). On my system PHP does not anti-alias; no matter if I am using positiv or negative values.
That's the code:

        $im = ImageCreateFromJpeg ("$motiv");
        $white = imagecolorclosest ($im, 255, 255, 255);
        $black = imagecolorclosest ($im, 0, 0, 0);
               ...

        $data = imagettftext($im, $karten_fontsize, 0, 
          $newx, $xstart, $black, $karten_font, $mytext[$o]);

It works but it just doesn't anti-alias.

     Hans


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-05 06:42 UTC] derick@php.net
Not a bug in PHP, bug in GD. That should be fixed in the upcoming? gd 2.0.2

Derick
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 05:03:41 2022 UTC