php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14253 build fails using AIX C 4.4 on AIX 4.3.3 box
Submitted: 2001-11-27 12:20 UTC Modified: 2001-11-27 12:53 UTC
From: paulo dot martins at cjf dot gov dot br Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.0CVS-2001-11-27 OS: AIX 4.3.3
Private report: No CVE-ID: None
 [2001-11-27 12:20 UTC] paulo dot martins at cjf dot gov dot br
Hi i am having trouble compiling the latest CVS with AIX C 4.4 on AIX 4.3.3.  The same problem have occured with 4.0.6 and a few snapshots i've downloaded. Have seen this problem related in some lists but no solution was provided.
Initiali i've used the --with-ingres directive too, but i'm trying the simplest configuration possible first :
Thats my .configure line :

/paulera/downloads/php4-200111270600 > ./configure --with-apxs=/usr/local/apache/bin/apxs

checking for a BSD compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking for mawk... no
checking for gawk... no
checking for nawk... nawk
checking whether make sets ${MAKE}... yes
Updated php_version.h
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... powerpc-ibm-aix4.3.3.0
checking host system type... powerpc-ibm-aix4.3.3.0
checking for mawk... (cached) nawk
checking for bison... no
checking for byacc... no
configure: WARNING: You will need bison if you want to regenerate the PHP parsers.
(that's the only warning i have during configure)

checking for gcc... no
( ... no more errors or warnings til the end ...)

during make, it's going fine until :

        /bin/sh ../libtool --silent --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I../main    -DAIX=43 -DUSE_PTHREAD_SERIALIZED_ACCEPT -DAIX_BIND_PROCESSOR -DMOD_SSL=208105 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../TSRM  -g -prefer-pic -c -o zend_qsort.lo `test -f zend_qsort.c || echo './'`zend_qsort.c
"zend_qsort.c", line 33.18: 1506-025 (S) Operand must be a modifiable lvalue.
"zend_qsort.c", line 34.18: 1506-025 (S) Operand must be a modifiable lvalue.
"zend_qsort.c", line 39.18: 1506-025 (S) Operand must be a modifiable lvalue.
"zend_qsort.c", line 40.18: 1506-025 (S) Operand must be a modifiable lvalue.
make: 1254-004 O c?digo de erro do ?ltimo comando ? 1.


Pare.
make: 1254-004 O c?digo de erro do ?ltimo comando ? 1.

If you need more information please ask. I'm fighting this problem for a week, reading everything i find on the net, bu couldn't find a solution. 

Thanks for your attention

Paulo

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-27 12:44 UTC] sniper@php.net
submitted twice.

 [2001-11-27 12:53 UTC] paulo dot martins at cjf dot gov dot br
sorry, clicked twice on the button...

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Jan 28 20:01:25 2020 UTC