php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14213 compiling problem
Submitted: 2001-11-24 15:52 UTC Modified: 2001-12-01 10:55 UTC
From: tobias at soft dot nu Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 4.0.6 OS: linux
Private report: No CVE-ID: None
 [2001-11-24 15:52 UTC] tobias at soft dot nu
Hi.  Doing a configure with these options,

'./configure' '--with-mysql=/usr/local/mysql' '--with-ldap' '--with-apxs=/usr/local/apache/bin/apxs' '--enabl
e-track-vars' '--with-zlib' '--with-imap=/usr/src/imap-2001.BETA.SNAP-0103302224/' '--with-gdbm' '--with-openssl=/usr/local/ssl' '-
-with-vpopmail' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-freetype' '--with-t1lib=/usr/local/' '--enable-versioning' '--enab
le-trans-sid' '--with-mcrypt' '--with-snmp' '--enable-ucd-snmp-hack'

and this results in this when i do make

make[2]: Entering directory `/usr/src/php-4.0.5/ext/snmp'
make[3]: Entering directory `/usr/src/php-4.0.5/ext/snmp'
/bin/sh /usr/src/php-4.0.5/libtool --silent --mode=compile gcc  -I. -I/usr/src/php-4.0.5/ext/snmp -I/usr/src/php-4.0.5/main -I/usr/src/php-4.0.5 -I/usr/local/apache/include -I/usr/src/php-4.0.5/Zend -I/usr/local/ssl/include -I/usr/local/include/freetype -I/usr/local//include -I/usr/src/imap-2001.BETA.SNAP-0103302224//include -I/usr/local/include -I/usr/local/mysql/include -I/usr/local/include/ucd-snmp -I/home/vpopmail/include -I/usr/src/php-4.0.5/ext/xml/expat/xmltok -I/usr/src/php-4.0.5/ext/xml/expat/xmlparse -I/usr/src/php-4.0.5/TSRM -I/usr/local/include/ucd-snmp -I/usr/local/apache/include -I/usr/src/php-4.0.5/Zend -I/usr/local/ssl/include -I/usr/local/include/freetype -I/usr/local//include -I/usr/src/imap-2001.BETA.SNAP-0103302224//include -I/usr/local/include -I/usr/local/mysql/include -I/usr/local/include/ucd-snmp -DLINUX=22 -DMOD_SSL=208103 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=12 -g -O2  -c snmp.c
In file included from snmp.c:59:
/usr/local/include/ucd-snmp/snmp_api.h:139: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:139: warning: no semicolon at end of struct or union
/usr/local/include/ucd-snmp/snmp_api.h:165: parse error before `}'
/usr/local/include/ucd-snmp/snmp_api.h:214: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:214: warning: no semicolon at end of struct or union
/usr/local/include/ucd-snmp/snmp_api.h:218: parse error before `*'
/usr/local/include/ucd-snmp/snmp_api.h:218: warning: data definition has no type or storage class
/usr/local/include/ucd-snmp/snmp_api.h:224: parse error before `}'
/usr/local/include/ucd-snmp/snmp_api.h:401: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:401: warning: no semicolon at end of struct or union
/usr/local/include/ucd-snmp/snmp_api.h:407: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:407: warning: no semicolon at end of struct or union
/usr/local/include/ucd-snmp/snmp_api.h:415: parse error before `}'
/usr/local/include/ucd-snmp/snmp_api.h:415: warning: data definition has no type or storage class
/usr/local/include/ucd-snmp/snmp_api.h:417: parse error before `name_loc'
/usr/local/include/ucd-snmp/snmp_api.h:417: `MAX_OID_LEN' undeclared here (not in a function)
/usr/local/include/ucd-snmp/snmp_api.h:417: warning: data definition has no type or storage class
/usr/local/include/ucd-snmp/snmp_api.h:419: conflicting types for `data'
/usr/src/php-4.0.5/main/php.h:233: previous declaration of `data'
/usr/local/include/ucd-snmp/snmp_api.h:420: `index' redeclared as different kind of symbol
/usr/include/string.h:240: previous declaration of `index'
/usr/local/include/ucd-snmp/snmp_api.h:421: parse error before `}'
/usr/local/include/ucd-snmp/snmp_api.h:610: parse error before `*'
/usr/local/include/ucd-snmp/snmp_api.h:628: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:630: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:633: parse error before `oid'
/usr/local/include/ucd-snmp/snmp_api.h:634: parse error before `*'
/usr/local/include/ucd-snmp/snmp_api.h:634: parse error before `*'
/usr/local/include/ucd-snmp/snmp_api.h:634: warning: data definition has no type or storage class
/usr/local/include/ucd-snmp/snmp_api.h:658: parse error before `*'
In file included from snmp.c:60:
/usr/local/include/ucd-snmp/snmp_client.h:51: parse error before `*'
/usr/local/include/ucd-snmp/snmp_client.h:52: parse error before `oid'
In file included from snmp.c:62:
/usr/local/include/ucd-snmp/snmp.h:288: parse error before `oid'
/usr/local/include/ucd-snmp/snmp.h:290: parse error before `oid'
In file included from snmp.c:64:
/usr/local/include/ucd-snmp/mib.h:274: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:278: parse error before `*'
/usr/local/include/ucd-snmp/mib.h:279: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:280: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:284: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:289: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:298: parse error before `*'
/usr/local/include/ucd-snmp/mib.h:299: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:300: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:301: parse error before `*'
/usr/local/include/ucd-snmp/mib.h:302: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:303: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:304: parse error before `*'
/usr/local/include/ucd-snmp/mib.h:305: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:306: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:307: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:308: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:309: parse error before `*'
/usr/local/include/ucd-snmp/mib.h:309: parse error before `oid'
/usr/local/include/ucd-snmp/mib.h:309: warning: data definition has no type or storage class
/usr/local/include/ucd-snmp/mib.h:310: parse error before `*'
/usr/local/include/ucd-snmp/mib.h:311: parse error before `*'
snmp.c:76: parse error before `objid_mib'
snmp.c:76: warning: data definition has no type or storage class
snmp.c: In function `php_snmp':
snmp.c:135: storage size of `session' isn't known
snmp.c:139: `oid' undeclared (first use in this function)
snmp.c:139: (Each undeclared identifier is reported only once
snmp.c:139: for each function it appears in.)
snmp.c:139: parse error before `name'
snmp.c:142: parse error before `root'
snmp.c:196: `MAX_NAME_LEN' undeclared (first use in this function)
snmp.c:198: `root' undeclared (first use in this function)
snmp.c:211: sizeof applied to an incomplete type
snmp.c:211: sizeof applied to an incomplete type
snmp.c:211: sizeof applied to an incomplete type
snmp.c:211: sizeof applied to an incomplete type
snmp.c:211: sizeof applied to an incomplete type
snmp.c:211: sizeof applied to an incomplete type
snmp.c:239: `name' undeclared (first use in this function)
snmp.c:250: `ASN_CONTEXT' undeclared (first use in this function)
snmp.c:250: `ASN_CONSTRUCTOR' undeclared (first use in this function)
snmp.c:271: dereferencing pointer to incomplete type
snmp.c:272: dereferencing pointer to incomplete type
snmp.c:272: dereferencing pointer to incomplete type
snmp.c:274: dereferencing pointer to incomplete type
snmp.c:274: dereferencing pointer to incomplete type
snmp.c:279: dereferencing pointer to incomplete type
snmp.c:279: dereferencing pointer to incomplete type
snmp.c:289: dereferencing pointer to incomplete type
snmp.c:289: dereferencing pointer to incomplete type
snmp.c:293: dereferencing pointer to incomplete type
snmp.c:293: `ASN_PRIMITIVE' undeclared (first use in this function)
snmp.c:294: dereferencing pointer to incomplete type
snmp.c:294: dereferencing pointer to incomplete type
snmp.c:295: dereferencing pointer to incomplete type
snmp.c:295: dereferencing pointer to incomplete type
snmp.c:296: dereferencing pointer to incomplete type
snmp.c:302: dereferencing pointer to incomplete type
snmp.c:303: dereferencing pointer to incomplete type
snmp.c:304: dereferencing pointer to incomplete type
snmp.c:305: dereferencing pointer to incomplete type
snmp.c:305: dereferencing pointer to incomplete type
snmp.c:306: dereferencing pointer to incomplete type
snmp.c:308: dereferencing pointer to incomplete type
snmp.c:308: dereferencing pointer to incomplete type
make[3]: *** [snmp.lo] Error 1
make[3]: Leaving directory `/usr/src/php-4.0.5/ext/snmp'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/php-4.0.5/ext/snmp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/php-4.0.5/ext'
make: *** [all-recursive] Error 1

tried to compile on earlier versions to, without any lucky.

plz help :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-24 18:32 UTC] sniper@php.net
First of all you should try the latest RC: 

http://www.php.net/~zeev/php-4.1.0RC3.tar.gz


Also add specific info about your system:

Which Linux distribution and version?
Which ucd-snmp version?
How did you install it?

 [2001-11-25 04:02 UTC] tobias at soft dot nu
ucd-snmp-4.2.2]# ./configure ; make ; make install

Apache/1.3.19

This is a slackware 7.1 dist with 2.4.3-pre6 kernel

Tried php-4.1.0RC3 with the same result
 [2001-11-25 04:40 UTC] mfischer@php.net
Can't reproduce with debian unstable and RC (but I'm using a different configure).

Try removing everything else from the configure line and only try with snmp. If it still doesn't work, then you system/ucd-snmp installation seems to be broken/misconfigured.

Feedback.
 [2001-11-25 04:48 UTC] tobias at soft dot nu
ucd-snmp-4.2.2]# ./configure ; make ; make install

Apache/1.3.19

This is a slackware 7.1 dist with 2.4.3-pre6 kernel

Tried php-4.1.0RC3 with the same result
 [2001-11-25 04:49 UTC] tobias at soft dot nu
Same error with './configure' '--with-snmp' '--enable-ucd-snmp-hack' '--with-openssl'

tried old versions of ucd-snmp to without anyluck.

tips of what to search for?


 [2001-12-01 10:55 UTC] mfischer@php.net
User reported the problem was due two different versions of openssl.

So, after all, not a PHP bug -> bogus.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 05:01:25 2020 UTC