php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14145 configure fails with apache 2.0.28
Submitted: 2001-11-20 06:59 UTC Modified: 2001-11-21 12:26 UTC
From: webmaster at d-s-a-g dot de Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: linux 2.2.14
Private report: No CVE-ID: None
 [2001-11-20 06:59 UTC] webmaster at d-s-a-g dot de
Hello from Berlin.
I try to build an apache with a static mod_php (on SuSE Linux 6.4 a 2.2.14 kernel)

I use this on php :
./configure --with-mysql=/usr/local/mysql --with-config-file-path=/etc --with-apache=../httpd-2_0_28 --enable-track-vars 
this fails with this 
<Configuring SAPI modules
<checking for AOLserver support... no
<checking for Apache module support via DSO through APXS... no
<checking for Apache module support... no
<configure: error: Invalid Apache directory - unable to find httpd.h under /home/dantho/httpd-2_0_28

if i use "--with-apache2" wich i found i a bug report 
./configure 
make 
make install
works fine (after using --with-apache2).

and then under httpd-2_0_28 

./configure --prefix=/usr/local/httpsd --enable-ssl --with-ssl=/usr/local/openssl --enable-suexec --with-suexec-caller=nobody --with-suexec-docroot=/home --enable-module=src/modules/php4/libphp4.a
make 
make install

erverything work also fine : BUT there is not mod_php included if i check it with ./httpd -l

What goes wrong here - any idea would be great.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-20 12:56 UTC] webmaster at d-s-a-g dot de
i now use :
.... --with-apxs2=... and php4-latest.tar.gz

that works fine with 2.0.28
 [2001-11-21 12:26 UTC] sniper@php.net
Not a bug -> bogus.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 03:01:23 2020 UTC