php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14141 Fatal error: fatal flex scanner internal error--end of buffer missed in ...
Submitted: 2001-11-20 05:25 UTC Modified: 2002-06-28 03:01 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: rfontana dot cs at clearstream dot com Assigned:
Status: Closed Package: iPlanet related
PHP Version: 4.0.6 OS: SunOS 5.6
Private report: No CVE-ID: None
 [2001-11-20 05:25 UTC] rfontana dot cs at clearstream dot com
Hello,

I am developing a website and when refreshing a screen or simply accessing to a page I have the following error: 

Fatal error: fatal flex scanner internal error--end of buffer missed in /www/docs/index.php on line 1

This can occurs at any page and giving me any line number. 
I read a lot about things like that and I think that it is due to the include I use. I think that it is due to the fact that the file included is not entirely read and t gives an error.

In fact, in my pages I use several includes that contains my functions library and my page header and footer.

This easily reproductible when I acces very fast the same page (eg: fast clics).

Can somebody confirm that I found the right cause of this error ?
Most important, Is there any solution to avoid those kind of problems ?


Thank you in advance,

Regards,

Fontana Renato

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-07 12:15 UTC] webmaster at worldtalk dot de
I do not admit... (Hope this is the same error, even it has not exactly the same "words" in it)

Fatal error: input in flex scanner failed in /home/worldtalk/public_html/info.php3 on line 1

This error I get, when I simply autorefresh a page (at 30 secs) - The error appears randomly... (perhaps more often if the server load is high)

=> I read, that it could have something to do with FastCGI compatibility...

mfg,
Stefan Koenig
 [2002-06-28 03:01 UTC] derick@php.net
Please try the latest NON stable snapshot (snaps.php.net) and reopen if it is not fixed.

Derick
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun May 28 00:03:40 2023 UTC