php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14044 GD(PNG) support stops working
Submitted: 2001-11-13 17:02 UTC Modified: 2001-11-14 08:05 UTC
From: csvieira at epm dot net dot co Assigned:
Status: Not a bug Package: GD related
PHP Version: 4.0.6 OS: Solaris 2.8 (Sparc)
Private report: No CVE-ID: None
 [2001-11-13 17:02 UTC] csvieira at epm dot net dot co
Upgrading from PHP 4.0.5 to 4.0.6 will make gd support stop working. GD, libpng and libjpeg are installed under /usr/local.
The error is: No PNG support in this PHP build
I am adding the --with-gd configure option. A downgrade to 4.0.5 solved the problem without changing nothing else.

I am using Apache 1.3.22 and installed with --with-apache=../apache_1.3.22 configure option.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-13 17:30 UTC] bate@php.net
--with-png-dir=
--with-jpeg-dir=

Use this configure commands to set PNGLIB and JPEG dir.
I try'd you configure and its works nice for me under 
FreeBSD 4.4
Redhat 7.1
SuSE 7.x

Tested PHP Versions
4.0.6
4.1.0RC1 + RC2
4.2.0... works nice with all
 [2001-11-14 06:35 UTC] sander@php.net
Include --with-zlib also. Does it work?
 [2001-11-14 07:40 UTC] csvieira at epm dot net dot co
It works ok. I already used --with-zlib, apache wont compile without it.
 [2001-11-14 08:05 UTC] sander@php.net
OK. If it's works, let's close this one.
 [2002-04-04 13:28 UTC] avialle at houra dot fr
compiling PHP 4.1.2 with apache 1.3.19 with gcc under solaris 8 sparc 64 bit also refuses to enable png support under gd. I have tryed all the good options (--with-png-dir=, --with-gd, etc.) all avalable gd, png, zlib versions that compiles fine under many directories... Always the same result: it compiles fine without errors or warnings, it works fine for everything exept for png or even jpeg support under gd (I can see that under phpinfo, or when I try to use png functions)... What the hell is wrong... I have made the same build under linux RedHat 6.2 or RedHat 7.2 and it works... Aaaahhh
 [2002-04-04 13:41 UTC] csvieira at epm dot net dot co
It is working for me with PHP 4.1.2 and Apache 1.3.22, and zlib 1.1.3

png and jpeg libs installed under /usr/local/

These were my configure options>

./configure --with-apache=../apache_1.3.22 --with-mm=/usr/local
--with-openssl=/usr/local/ssl
--with-imap=../imap-2001a
--with-imap-ssl=/usr/local/ssl
--with-xml
--with-mysql=/usr/local/mysql
--with-pgsql=/export/pgsql
--enable-track-vars
--enable-versioning
--with-mcrypt
--with-gd
--with-png-dir=/usr/local
--with-jpeg-dir=/usr/local
--enable-ftp
--enable-sysvsem
--enable-sysvshm
--with-zlib

It compiles and works OK under Solaris8/Sparc
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 02 20:03:58 2022 UTC