php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13998 + in commandline disappears
Submitted: 2001-11-09 11:46 UTC Modified: 2002-04-10 19:30 UTC
From: pieter dot morisse at asro dot kuleuven dot ac dot be Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.6 OS: windows 2000 - apache server
Private report: No CVE-ID: None
 [2001-11-09 11:46 UTC] pieter dot morisse at asro dot kuleuven dot ac dot be
If I echo the query_string, I get:
case=1&file_id=file_35&id=35&name=Grondplan%20T+1.jpg&ftype=drawing

but when I ask the following:
echo $name;
it gives me:
Grondplan T 1.jpg

the + has disappeared.

can anyone help me.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-09 12:10 UTC] sander@php.net
Dupe of #12219
 [2001-11-09 12:13 UTC] sander@php.net
Or, if you meant that an url like http://localhost/file.php?var=foo+bar resulted in $var being "foo bar", RTM: http://www.php.net/manual/en/language.variables.external.php
 [2001-11-12 02:46 UTC] pieter dot morisse at asro dot kuleuven dot ac dot be
I'm sorry, but I've read that page and I don't see anything about this problem. Not even in the notes.
 [2002-04-10 19:30 UTC] sniper@php.net
see #12219 for explanation.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 16:01:23 2020 UTC