php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13948 mysql_free_result giving error for valid $result
Submitted: 2001-11-05 22:36 UTC Modified: 2001-11-06 09:47 UTC
From: rohan dot hawthorne at nt dot gov dot au Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.4pl1 OS: Red Hat Version 2.4
Private report: No CVE-ID: None
 [2001-11-05 22:36 UTC] rohan dot hawthorne at nt dot gov dot au
Here is the code:

$SQL = "UPDATE tblAsset SET fldAssetId = 2, fldAssetCode = 'bc04495' WHERE fldAssetId = 2";
$result = mysql_query("$SQL");
if (!$result) { echo("ERROR: " . mysql_error() . "$SQL");   }
mysql_free_result ($result);

Here is the error:
Warning: Supplied argument is not a valid MySQL result resource in /var/www/html/itss/ProcessAsset.php on line 4

If an UPDATE doesn't produce a positive $result, why does the first error check (line 3) not produce an error ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-06 09:46 UTC] jpm@php.net
User submitted bug several times by accident (wasn't this fixed ?)

Not a bug -> bogus

--Joao
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 25 04:01:28 2024 UTC