php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13935 ../ext/informix/ifx.ec(996) : Freeing 0x00250CF8 (372 bytes script=-
Submitted: 2001-11-05 10:53 UTC Modified: 2001-11-12 05:58 UTC
From: pgalan at cscamaras dot es Assigned:
Status: Closed Package: Informix related
PHP Version: 4.0.6 OS: SunOs 5.6
Private report: No CVE-ID: None
 [2001-11-05 10:53 UTC] pgalan at cscamaras dot es
I got the following error:

/Compile-PATH/php-4.0.6/ext/informix/ifx.ec(996) : Freeing 0x00250CF8 (372 bytes), script=-

when i execute the following script:

#!/usr/local/bin/php
<?php

 if ( !($db = ifx_connect($bd,$user,$passw) ) ) {
  echo "No hay conexion con la base de datos".ifx_errormsg();
  exit;
 }

 $sql = "SELECT * FROM xxxx WHERE yyyy LIKE 'zz%'";
 if ( !$query = (ifx_query($sql,$db)) ) {
  echo "Se ha producido un error en la conexion, intentelo mas tarde";
  exit;
 }
?>


My informix client is I-Connect 2.50

Thaks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-10 04:27 UTC] sniper@php.net
Does this happen with latest CVS snapshot from 
http://snaps.php.net/ ?

 [2001-11-12 04:30 UTC] pgalan at cscamaras dot es
No, I doesn't happen.


What can I do ??   I'm afraid of making the latest version avaiable in a production enviroment.


Thanks.
 [2001-11-12 04:37 UTC] derick@php.net
Just wait until the next release then. This is not a huge problem. It's only a warning from the Zend Engine that it frees some unfreed memory.

Derick
 [2001-11-12 04:54 UTC] pgalan at cscamaras dot es
No, I doesn't happen.


What can I do ??   I'm afraid of making the latest version avaiable in a production enviroment.


Thanks.
 [2001-11-12 04:58 UTC] derick@php.net
Just wait until the next release then. This is not a huge problem. It's only a
warning from the Zend Engine that it frees some unfreed memory.

Derick

(And leave it closed this time)
 [2001-11-12 05:06 UTC] pgalan at cscamaras dot es
I've noticed that  there is still a bug from previous releases in the latest snapshot

If yout try to execute any php script like a shell script, you know:

#!/usr/local/bin/php

...

php includes  this first line in the result output.


This bug is reported previously and the solution is making a simple change in the
.../sapi/cgi/cgi_main.c module about line 732:

 else if (retval == SUCCESS) {
                        /* #!php support */


 [2001-11-12 05:58 UTC] derick@php.net
That is a different bug, and already reported. Please leave this one closed for now.

Derick
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 13:01:29 2024 UTC