php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13655 undefined symbol: stat
Submitted: 2001-10-12 11:28 UTC Modified: 2003-02-26 08:56 UTC
Votes:8
Avg. Score:4.8 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:1 (14.3%)
Same OS:2 (28.6%)
From: francois at be dot wanadoo dot com Assigned:
Status: Closed Package: Informix related
PHP Version: 4.0.6 OS: RedHat Linux/Alpha 7.1
Private report: No CVE-ID: None
 [2001-10-12 11:28 UTC] francois at be dot wanadoo dot com
Syntax error on line 205 of /usr/local/httpd/conf/httpd.conf
Cannot load /usr/local/httpd/libexec/libphp4.so into server:
/usr/local/informix/lib/esql/libifos.so: undefined symbol: stat

esql -V:
INFORMIX-ESQL Version 9.40FC2A

Apache:  1.3.19
PHP: 4.0.6
RedHat Linux: 7.1
glibc: 2.2.3

We have the same problem with newer Intel Informix Client SDK
(the one you can download from www.informix.com)

One esql that works on Intel Linux is:
INFORMIX-ESQL Version 9.30.UC1

I unfortunately don't have an older Redhat Linux/Alpha Informix
Client SDK to try.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-11 07:29 UTC] gilles at nedostoupof dot be
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/informix/lib/esql/libifgen.so: undefined symbol: stat

esql -V:
INFORMIX-ESQL Version 9.51.UC3

Apache: 1.3.22
PHP: 4.1.1
Linux Mandrake: 8.1
glibc: 2.2.4

Same problem and no fix for that ;-)

Gilles.
 [2002-03-30 08:54 UTC] frederic dot diverrez at steria dot com
same problem whith mandrake 8.1
 [2002-06-15 20:38 UTC] sniper@php.net
This snapshot _should_ fix the problem:

http://snaps.php.net/php4-latest.tar.gz

It works fine for me with the 2.70.UC3 which is the latest I found from the informix site. (it's same as 9.30.UC1, wierd versions they have :)


--Jani

 [2002-06-17 07:09 UTC] john at astarte dot de
Same problem with Suse 8.2, regardless of whether latest snapshot or stable version is used.
 [2002-07-16 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-02-26 08:47 UTC] nobbie@php.net
The issue is with glibc. 'stat', 'lstat' and a few others have moved to a libc_nonshared.a archive, and out of libc. 

Check your /usr/lib/libc.so file, it should look something like: GROUP ( /lib/libc.so.6 /usr/lib/libc_nonshared.a )

if that still doesn't work, you need to recompile your libifgen.so from the libifgen.a.

Here's how:

mkdir /tmp/ifx
cd /tmp/ifx
ar x $INFORMIXDIR/lib/esql/libifgen.a
gcc -shared -o libifgen.so *.o
cp libifgen.so $INFORMIXDIR/lib/esql
 [2003-02-26 08:56 UTC] sniper@php.net
restore original email..

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 14:01:32 2024 UTC