php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13573 persistant connections sometimes hand
Submitted: 2001-10-06 12:08 UTC Modified: 2002-08-13 23:55 UTC
From: olivier at lx dot student dot wau dot nl Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.0.6 OS: Linux 2.2.19
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: olivier at lx dot student dot wau dot nl
New email:
PHP Version: OS:

 

 [2001-10-06 12:08 UTC] olivier at lx dot student dot wau dot nl
when using interbase + persistant connections, I sometimes get this:

[Sat Oct  6 17:43:19 2001] [error] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /home/pkedu/webman6/includes/datasource.inc.php on line 2

that line is:
$ibconnectid = ibase_pconnect("/usr/local/interbase/data/webman6", "fake", "fake");

all php pages using this link are dead from that moment. If I change the line to
$ibconnectid = ibase_connect("/usr/local/interbase/data/webman6", "fake", "fake");
everything works as expected again (but slower).

This happens after a week or so running with persistant connections. The problem is gone after a apache restart. If more info is needed please let me know how to provide it.

thanks,
	Olivier Sessink

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-13 23:55 UTC] iliaa@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 17:01:25 2020 UTC