php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13538 The variable names do not use HTTP_*_VARS format
Submitted: 2001-10-04 05:47 UTC Modified: 2001-10-04 10:16 UTC
From: marco at starfarm dot it Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.0.6 OS: Linux Slackware 4.0
Private report: No CVE-ID: None
 [2001-10-04 05:47 UTC] marco at starfarm dot it
All the PHP variables do not have the name HTTP_*_VARS, where * = {GET,POST,ENV,SERVER,COOKIE}

They have a short name like:

_GET["...
_POST["...

and so on

Main settings of the php.ini are:

gpc_order = GPC 
register_argc_argv = Off 
register_globals = Off
safe_mode = Off 
variables_order = EGPCS

I am running Apache 1.3.20. The PHP I have tried so far are 4.0.7RC1 and 4.0.8-dev (I cannot use the 4.0.6 because of the bug http://bugs.php.net/bug.php?id=11776)

A very simple phpinfo() shows all the variables in the last table with the "short version" of their name...

Regards,

Marco

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-04 09:14 UTC] sniper@php.net
Isn't it a great new feature? 
Both the long names and short names work.

--Jani

 [2001-10-04 09:58 UTC] marco at starfarm dot it
That is not completely true...

The only vars that are working are the short ones...

Regards,

Marco
 [2001-10-04 10:16 UTC] sniper@php.net
Both work for me with latest CVS.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 07:01:24 2020 UTC