php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13530 IMAP will not disable
Submitted: 2001-10-03 11:17 UTC Modified: 2001-10-04 15:47 UTC
From: borthner at rongenet dot sk dot ca Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.0.6 OS: Mandrake Linux 7.0
Private report: No CVE-ID: None
 [2001-10-03 11:17 UTC] borthner at rongenet dot sk dot ca
I am attempting to upgrade my PHP installation to 4.06. I configured php with the following line:

./configure --with-apxs=/usr/sbin/apxs --with-zlib --with-regex=system --enable-trans-sid --disable-debug --with-mysql

The configure script, make, and make install all appear to run normally. However, when I restart Apache (1.3.9-Mandrake rpms), I get the following message:

Syntax error on line 74 of /etc/httpd/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/libimap.so.4: undefined symbol:mm_dlog

As you will notice from my configure line, I haven't included imap support, so why is an imap library killing my installation? I have checked my php.ini, and there is no reference to the imap.so, so it's not an extension that it's trying to load. I've even explicitly disabled imap in the configure line - same result. What's going on?

For your further information, my system has imap libraries from a courier-imap/sqwebmail installation, not the uw imap, which is why I have not tried to include imap in my php.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-03 11:21 UTC] jeroen@php.net
A extension=...imap.so line is still in your php.ini

Please go to www.php.net/support.php for support questions.
 [2001-10-03 12:05 UTC] borthner at rongenet dot sk dot ca
Read my original posting - imap.so is NOT in my php.ini file. This is not the source of the problem.
 [2001-10-04 15:47 UTC] jeroen@php.net
Please check that it's the right php.ini that is used (make an intentional syntax error and see wether PHP complains).

also grep through your /etc/apache dir for imap, the reference could be in there.

If that doesn't solve it, ask your support question on www.php.net/support.php, because this is very likely not a bug.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 00:01:24 2020 UTC