php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1350 Informix SQLLVARCHAR Crashes Netscape 3.5.1
Submitted: 1999-04-26 14:20 UTC Modified: 2002-06-16 08:30 UTC
From: email at destryhines dot com Assigned:
Status: Not a bug Package: Reproducible Crash
PHP Version: 3.0.7 OS: Solaris 2.6
Private report: No CVE-ID: None
 [1999-04-26 14:20 UTC] email at destryhines dot com
I have an Informix 9.14.UC3 database that has some data in ifxmrdata or html data types. These fields contain data beyond 256 bytes, often more then 11,000 bytes. 

I have tried to get to the data using two different methods. 

1) Cast the unsupported data types to lvarchar. An example would be my_big_field::lvarchar. This just hangs the php program and never seems to return.

2) Cast the unsupported data types to lvarchar then char(n). An example would be my_big_field::lvarchar::char(8192). This works for some tables but has two problems. a) On some fields it crashes the web server with a signal 11. b) If the data is only 2 bytes long I still get 8192 bytes of data because the database fills the extra bytes with spaces. This does not work because there are instances where I need 30K of data and I can't return 30K of spaces for each record. These problems occur whether I use the ifx_htmltbl_result or retrieve the individual row.

I played around with the source code and found some bazaar results. If I change the SQLLVARCHAR handler in the ifx_htmltbl_result section to a simple loop that does a putchar(ch) for each character, it will output all the data but still cause the signal 11. If instead put out a fixed character in place of the actual character, like an 'x', then I get all the x's returned and the server does NOT crash... If I output the actual character then a fixed character, like "w:o:r:d:", the server does NOT crash. It's only when I output the actual characters that the server crashes. It doesn't seem to matter what is in the actual data. The content is only regular html content (words, metatags). This is so strange. I have tried outputting extra spaces before and after the actual data but the server crashes.

I really need to find a work around for this problem. Is it possible?

--Destry

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:30 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC