php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13482 apache processes SEGFAULT
Submitted: 2001-09-28 13:50 UTC Modified: 2001-12-26 18:52 UTC
From: jerome dot ponsin at francetrader dot com Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.6 OS: Linux RH7.1 - 2.4 SMP
Private report: No CVE-ID: None
 [2001-09-28 13:50 UTC] jerome dot ponsin at francetrader dot com
When enable output compression in php.ini by :
output_handler = ob_gzhandler

I found in my apache error_log
[Wed Sep 26 13:29:40 2001] [notice] child pid 4858 exit signal Segmentation fault (11)

I compiled php into apache with :
./configure --with-apache=/root/apache_1.3.20 --with-mysql --enable-ftp --enable-inline-optimization --disable-debug --with-zlib

Thanks for help,
Jerome

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-01 23:24 UTC] sniper@php.net
Does this happen with latest CVS snapshot from http://snaps.php.net/ ?

 [2001-10-02 08:24 UTC] jerome dot ponsin at francetrader dot com
I can't tell you that because on my test server (with 
very small load) I can't reproduce that... It seems to
only happen on middle/high load. And I can't test 
last snapshot on my production server (but the problem
exists in 4.0.5 and also in 4.0.6),
regards,
Jerome
 [2001-12-05 04:34 UTC] jerome dot ponsin at francetrader dot com
I tried with latest CVS snapshot from http://snaps.php.net/ 
(date : 2001-12-03)
and it's the same thing

[notice] child pid 11785 exit signal Segmentation fault (11)
 [2001-12-05 05:54 UTC] jerome dot ponsin at francetrader dot com
Looks same bug than #8334 but it is not closed for me
(even with 4.0.5, 4.0.6 or latest snapshot)

 [2001-12-05 07:19 UTC] sniper@php.net
Please add a GDB backtrace of this crash.
(compile PHP with --enable-debug first)

--Jani

 [2001-12-26 18:52 UTC] lobbin@php.net
No feedback. Closing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 22:01:26 2020 UTC