php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13412 IMAP don't compile propertly
Submitted: 2001-09-24 05:22 UTC Modified: 2001-09-25 09:37 UTC
From: autoinfo at auto dot ru Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.0.6 OS: FreeBSD 4.4-RC
Private report: No CVE-ID: None
 [2001-09-24 05:22 UTC] autoinfo at auto dot ru
I have :
c-client library
All headers are deployed in /usr/local/include/c-client directory.

My config-file for make is :
------------------------------------ QUOTE ---------------------------------------------
./configure \
--with-mod_charset \
--enable-track-vars \
--enable-sysvsem \
--enable-sysvshm \
--enable-shared \
--with-apache=/usr/local/src/apache \
--with-pgsql=/usr/local/pgsql \
--with-mysql=/usr/local \
--with-gd=/usr/local \
--with-jpeg-dir=/usr/local \
--without-ttf \
--without-ndbm \
--without-dbm \
--without-gdbm \
--with-imap \
--with-xml > /dev/null
------------------------------------ EDN OF QUOTE ---------------------------------------------


Then, when I'm trying to configure Apache, the process stops, as described below:
------------------------------------ QUOTE ---------------------------------------------
Configuring for Apache, Version 1.3.20
 + using installation path layout: Apache (config.layout)
 + activated php4 module (modules/php4/libphp4.a)
 + activated auth_pgsql module (modules/auth_pgsql/mod_auth_pgsql.c)
 + activated rru module (modules/extra/mod_rru.o)
 + activated auth_mysql module (modules/auth_mysql/libauth_mysql.a)
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for FreeBSD 4.4 platform
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
    o charset_module uses ConfigStart/End
    o php4_module uses ConfigStart/End
    o auth_pgsql_module uses ConfigStart/End
    o auth_mysql_module uses ConfigStart/End
 + checking sizeof various data types
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed.  The below error output from the compilation
** test will give you an idea what is failing. Note that
** Apache requires an ANSI C Compiler, such as gcc.

cd ..; gcc  -I/usr/local/include/mysql  -funsigned-char -DRUSSIAN_APACHE -I/usr/
local/src/php -I/usr/local/src/php/main -I/usr/local/src/php/main -I/usr/local/s
rc/php/Zend -I/usr/local/src/php/Zend -I/usr/local/src/php/TSRM -I/usr/local/src
/php/TSRM -I/usr/local/src/php -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./
apaci`     -o helpers/dummy helpers/dummy.c   -L/usr/local/lib/mysql -lmysqlclie
nt -lcrypt   -L/usr/local/pgsql/lib -lpq  -R/usr/local/lib -R/usr/local/lib/mysq
l -R/usr/local/pgsql/lib  -rdynamic -L/usr/local/lib -L/usr/local/lib/mysql -L/u
sr/local/pgsql/lib -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodph
p4  -lpam -lc-client4  -lpq -lmysqlclient -lcrypt -lpam -lgd -ljpeg -lcrypt -lm
 -lcrypt   -lcrypt
/usr/local/lib/libc-client4.so: undefined reference to `mm_expunged'
/usr/local/lib/libc-client4.so: undefined reference to `mm_diskerror'
/usr/local/lib/libc-client4.so: undefined reference to `mm_lsub'
/usr/local/lib/libc-client4.so: undefined reference to `mm_flags'
/usr/local/lib/libc-client4.so: undefined reference to `mm_fatal'
/usr/local/lib/libc-client4.so: undefined reference to `mm_nocritical'
/usr/local/lib/libc-client4.so: undefined reference to `mm_notify'
/usr/local/lib/libc-client4.so: undefined reference to `mm_searched'
/usr/local/lib/libc-client4.so: undefined reference to `mm_status'
/usr/local/lib/libc-client4.so: undefined reference to `mm_login'
/usr/local/lib/libc-client4.so: undefined reference to `mm_list'
/usr/local/lib/libc-client4.so: undefined reference to `mm_critical'
/usr/local/lib/libc-client4.so: undefined reference to `mm_exists'
------------------------------------ EDN OF QUOTE ---------------------------------------------

Also, I've tried to compile IMAP with PHP 4.0.6 and with snaps version, with I have obtained from  http://snaps.php.net:8080/php4-200109240135.tar.gz
Unfortunately, the result was same...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-25 09:37 UTC] sniper@php.net
You're using unsupported shared compile of c-client.
use the static library and it will work. Not a bug.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 16 22:03:34 2021 UTC