php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13396 php4ts.dll crashes on shutdown of Windows
Submitted: 2001-09-22 10:19 UTC Modified: 2002-01-01 07:51 UTC
From: steve at srtware dot com Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 4.0.6 OS: Windows 98 SE
Private report: No CVE-ID: None
 [2001-09-22 10:19 UTC] steve at srtware dot com
I think this is really a "me too" for bug #12270, but I can't add to that report.

I have also had this happen on I believe just 4.0.5 and 4.0.6, on Windows 98 SE and PWS. Earlier versions did not have this problem.  I am using PHP.EXE.

To reproduce, open ANY .php page in a browser, and shut down Windows. If I open no .php pages (i.e. PHP never runs), I do not get the error.

I have tried putting php4ts.dll in my \windows\system folder, and adding it to the PATH, to no avail.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-01 07:51 UTC] steve at srtware dot com
After some research I now believe my issue was caused by a configuration error in Personal Web Server 4.0.  I determined that despite my setting the registry's Script Map to use PHP.EXE, PWS was really using PHP in ISAPI mode, which I hadn't noticed from the phpinfo() report.  This setting appears to be in the metabase.bin file, which is apparently not editable on Windows 9x.  I finally uninstalled PWS and installed Apache's web server to fix the problem.  I suspect an uninstall and reinstall of PWS would have worked also since the uninstall deletes the metabase.bin file.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Dec 10 08:01:24 2019 UTC