php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13384 Enctype multipart/form-date
Submitted: 2001-09-21 20:40 UTC Modified: 2001-10-17 06:41 UTC
From: arwinux at yahoo dot com Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.6 OS: Linux hurricane 2.2.19-5tr
Private report: No CVE-ID: None
 [2001-09-21 20:40 UTC] arwinux at yahoo dot com
I'm not sure it's a bug. But I have checked all of my configuration system and I think the problem is not in my system.
The problem is :
When i used tag form and enctype=multipart/form-data (we must use this for input type=file or for upload file),
There's no variables delivered to 'action' file.
The problem disappeared if I use PHP 4.0.5 with the exactly same script and everthing is ok for the form.

That's all, pls reply if you're have found the solution for me.
Thanks a lot

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-21 21:10 UTC] hholzgra@php.net
Is "Linux hurricane" a RedHat based distribution
and you are using the distributions PHP RPMs?


 [2001-09-22 04:23 UTC] jeroen@php.net
Can you provide a short script which is showing this problem?

And you should use enctype="multipart/form-data" (with the quotes), because without it's invalid HTML (only [a-zA-Z0-9.-]+ is allowed in HTML-attribute values without quotes, see http://www.htmlhelp.com/reference/html40/structure.html#attributes)
 [2001-10-17 06:41 UTC] sander@php.net
No feedback. Closing.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 18:01:24 2019 UTC