php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13377 image copyresampled doesn't use srcx and srcy
Submitted: 2001-09-21 12:19 UTC Modified: 2003-02-12 21:44 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: tai at projectsomewhere dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.3.0 OS: Linux and win98
Private report: No CVE-ID: None
 [2001-09-21 12:19 UTC] tai at projectsomewhere dot com
imagecopyresampled always uses the 0, 0 as the srcx and srcy. it should use a specified x and y like imagecopyresized.

I've setup an example to demonstrate, you can find it at: http://www.triptosomewhere.com/sizing.php source is included there.

also, the select box which should let me choose which type of bug this is only has one option ( -Please Select- ), so apologies if this doesn't go directly to the correct place.

Cheers
Tai :)

below is a snip of phpinfo.

'./configure' '--with-mysql' '--with-apache=../apache_1.3.20' '--enable-track-vars' '--with-xml' '--enable-memory-limit=yes' '--enable-bcmath' '--with-gd=../gd-2.0.1' '--enable-gd-native-tt' '--enable-gd-imgstrttf' '--with-gdbm=/usr/include' '--enable-calendar' '--with-png-dir=/usr/lib' '--with-zlib-dir=/usr/include' '--with-freetype-dir=/usr/local/include/freetype2' '--with-jpeg-dir=/usr/local/lib' '--with-mcrypt' '--enable-trans-sid' '--with-sablot=/usr/local/lib' '--with-imap' '--enable-sablot-errors-descriptive'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-24 14:02 UTC] sander@php.net
Duplicate of 12780.
 [2002-06-18 18:53 UTC] sniper@php.net
Not a bug in PHP.

 [2002-06-19 03:53 UTC] markonen@php.net
Well, not for 4.0.6, but now that we've forked gd the bugs 
will be ours as well...
 [2002-06-19 04:24 UTC] mfischer@php.net
Please test with eiher http://snaps.php.net/php4-latest.tar.gz (configure --with-gd=php) or try the win32 snapshot http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-07-20 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-02-10 19:10 UTC] dima at glagol dot ru
Me too! 
php 4.3.0 
libgd2-2.0.4
 [2003-02-12 19:46 UTC] nicos@php.net
Opened back then.

Are you using the bundled GD with PHP4.3.0 ?
 [2003-02-12 21:44 UTC] sniper@php.net
This is fixed by using latest STABLE snapshot and the bundled GD library.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 12:03:47 2022 UTC