php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13290 extension_dir directive is not working
Submitted: 2001-09-13 14:11 UTC Modified: 2001-10-08 09:02 UTC
From: ralourenco at uol dot com dot br Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0.6 OS: Win2000 SP2
Private report: No CVE-ID: None
 [2001-09-13 14:11 UTC] ralourenco at uol dot com dot br
No matter the directory I put in the directive extension_dir in php.ini file, the extension is unloadable.
I receive the message: 

"Unable to load dynamic library 'c:\inetpub\php\extensions\php_oci8dll' - Cannot find specified module"
and
PHP Warning: Unable to load dynamic library 'c:\inetpub\php\extensions\php_oci8.dll' 

I've tryed many ways in php.ini file:
extension_dir = "c:\inetpub\php\extensions"
extension_dir = "c:\inetpub\php\extensions\"
extension_dir = "c:\\inetpub\\php\\extensions\\"
extension_dir = "c:\\inetpub\\php\\extensions"
extension_dir = c:\inetpub\php\extensions
extension_dir = c:\inetpub\php\extensions\
extension_dir = c:/inetpub/php/extensions/
extension_dir = c:/inetpub/php/extensions

None of these worked.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-13 22:07 UTC] sniper@php.net
Do you have the Oracle client libraries installed on
you computer?

 [2001-10-08 09:02 UTC] sander@php.net
No feedback. Probably not a bug in PHP. Closing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 07:01:23 2020 UTC