php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13194 PHP4,jdk1.2.2
Submitted: 2001-09-07 10:37 UTC Modified: 2001-09-08 08:20 UTC
From: kirannadgir at email dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.6 OS: SUSE 7.0 linux intel i386
Private report: No CVE-ID: None
 [2001-09-07 10:37 UTC] kirannadgir at email dot com
I tried installing php4 with java support 
my php.ini file looks something like this
[Java]
java.class.path =/usr/local/lib/php/php_java.jar:/usr/local/httpd/htdocs/phpjava
java.home = /usr/lib/jdk1.2.2/bin:/usr/lib/jdk1.2.2/jre/bin
java.library = /usr/lib/jdk1.2.2/jre/lib/i386/classic/
java.library.path = /usr/lib/jdk1.2.2/lib:/usr/local/lib/php/extensions/no-debug-non-zts-20001222/:/usr/lib/jdk1.2.2/jre/bin/usr/lib/jdk1.2.2/jre/bin/i386/native_threads:/usr/lib/jdk1.2.2/jre/lib/i386/classic
extension=libphp_java.so 

i get the following error..


Fatal error: Unable to load Java Library /usr/lib/jdk1.2.2/jre/lib/i386/classic/libjvm.so, error: libhpi.so: cannot open shared object file:
No such file or directory in /usr/local/httpd/htdocs/phpjava/testjava.php on line 2

I haven't found any solution to this problem till now.....

pleassssseeeeeeeeeeeeee HELP !!!!!!!!!!!!!!!!!!!!!!!!








Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-07 11:08 UTC] sander@php.net
Duplicate of 13194
 [2001-09-08 08:20 UTC] sniper@php.net
submitted twice
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 02:01:31 2024 UTC