php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13188 Unable to load dynamic library php_interbase.dll
Submitted: 2001-09-06 19:41 UTC Modified: 2001-09-06 20:27 UTC
From: humano at bigfoot dot com Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.0.6 OS: Windows 2000 Service Pack 2
Private report: No CVE-ID: None
 [2001-09-06 19:41 UTC] humano at bigfoot dot com
This bug has been reported before but due to lack of feedback the developers seem to have decided to close it. But the bug remains.

After uncommenting the "extension=php_interbase.dll" line in php.ini, php shows the following error in a dialog box:

    Unable to load dynamic library 'c:\php\extensions\php_interbase.dll'

This happens:
  - To php_interbase.dll but not with php_imap.dll and others.
  - No matter PHP is running as CGI or ISAPI module
  - A user (http://marc.theaimsgroup.com/?l=php-db&m=97812982300192&w=2) has reported success by putting PHP_INTERBASE.DLL in the SYSTEM32 folder. But I haven't.
  - I've seen it happen in four computers: two of them running Win2000 Server and the other two running Win2000 Professional.

What is strange about this bug is that I've installed PHP with this module in my computer once in the past and it worked...

This bug has compromised the use of PHP in one of my company's project. Who knows how many PHP+Interbase projects have been aborted because of this bug?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-06 19:46 UTC] sniper@php.net
Perhaps this manual page would give some help:
http://www.php.net/manual/en/install-windows.php#install.windows.extensions

ie. You propably haven't copied the needed dll file
from dlls folder in the distribution package to the 
system32 folder..

--Jani



 [2001-09-06 20:17 UTC] humano at bigfoot dot com
It was that, Jani! I copied all the DLLs from the \php\dlls directory to c:\winnt\system32 and it worked.

The problem is that the "Install.txt" isn't clear about the need to do this. It just says:

   ?Some DLLs are required for some PHP extensions. Please copy them to
   your to your windows/system (Win9.x) or winnt/system32 (WinNT, Win2000)
   directory. If you already have these DLLs installed on your system,
   overwrite them only if something is not working correctly.
   Before overwriting them, it is a good idea to back them or move them to
   another folder - just in case something goes wrong.?

But I think it should mention, like the manual web page does, that for some extensions to work the DLLs needed are in the \php\dlls directory. Most people look at the "Install.txt" for installation instructions. I never imagined that the installation instruction in the php web site would contain vital information that the "Install.txt" didn't have.
 [2001-09-06 20:27 UTC] sniper@php.net
Thus closed. The installation instructions have already
been fixed to contain a note about this. The manual
is ALWAYS the place to find the latest and most correct
information, though.

--Jani


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 03:05:45 2022 UTC