php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13113 rpm install -> curl_global_init undefined
Submitted: 2001-09-03 13:19 UTC Modified: 2001-09-04 19:24 UTC
From: bro at ne9 dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.0.6 OS: RH 6.2+linux 2.2.15
Private report: No CVE-ID: None
 [2001-09-03 13:19 UTC] bro at ne9 dot com
This is probably my own config problem, and not a real bug, but...

Just installed php-4.0.6-6.i386.rpm
after updating a number of libraries
including curl-ssl-7.6-1.i386.rpm

Running php on the commandline only produces:
php: error while loading shared libraries: 
php: undefined symbol: curl_global_init

My /usr/bin contains:
lrwxrwxrwx   1 root           16 Sep  3 10:40 /usr/lib/libcurl.so -> libcurl.so.1.0.0*
lrwxrwxrwx   1 root           16 Sep  3 10:40 /usr/lib/libcurl.so.1 -> libcurl.so.1.0.0*
-rwxr-xr-x   1 root       113921 Jan 27  2001 /usr/lib/libcurl.so.1.0.0*

I'm pretty ignorant of libraries, so k.i.s.s. if at all possible.. (thanks) but if any other info will help,
I'll be watching my email..

Note: php3 apache module is working on my system.

cheers,
John

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-03 13:52 UTC] bro at ne9 dot com
fwiw:
(gdb) run php
Starting program: /usr/bin/php php
then: then/endif not found.
/usr/bin/php: error while loading shared libraries: /usr/bin/php: undefined symbol: curl_global_init

Program exited with code 0177.

Again, this is an rpm, I don't know what the compile
directives or options were.. 
 [2001-09-03 14:19 UTC] sterling@php.net
You need to update your cURL installation to the latest version and then it should work.
 [2001-09-03 16:50 UTC] bro at ne9 dot com
I grabbed libcurl.so.2 in the ConnectivaLinux 
libcurl-7.7.1-2cl.i386.rpm (the only one offered,
and had to use --nodeps because of complaints that
curl 2cl conflicts with curl 1cl ?duh?)

but I still get the same 'undefined curl_global_init'.

Again, I started with curl-ssl-7.6-1.i386.rpm
then got               libcurl-7.7.1-2cl.i386.rpm

Another detail: libs from openssl.0.9.6..rpm were not
properly registered in my rpm db so installing libcurl
also complained - even though they're there!

But then I noticed there's libcrypto and libssl
0.9.6 a & b and I've got b. So I've made links for the 'a' versions to the 'b' versions.. am I screwing something up here? 
 
 [2001-09-04 07:39 UTC] bro at ne9 dot com
Following Sterling's advice, I upgraded libcurl to 2.0.1 (which does contain the string curl_global_init) via curl-7.8.1-1.i386.rpm from haxx.se  
but no change..  still undefined.Removed curl, removed php,  
reinstalled the rpms, reran ldconfig manually  
-- still no go. Guess I could try to compile from source,  
(but, why should it be necessary?)
 [2001-09-04 19:24 UTC] sniper@php.net
You're doing something wrong there. libcurl 7.8.1 works
just fine here. Please ask further support questions 
on the mailing lists, this is not any bug.

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 08:01:26 2019 UTC