php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12995 "Failed opening ... in Unknown on line 0
Submitted: 2001-08-28 07:04 UTC Modified: 2003-09-29 21:03 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: se at brainbits dot net Assigned:
Status: Not a bug Package: Scripting Engine problem
PHP Version: 4.3.3 OS: SuSE Linux 7.2
Private report: No CVE-ID: None
 [2001-08-28 07:04 UTC] se at brainbits dot net
I get this warning:
Warning: Failed opening 'path_to_a_script' for inclusion (include_path='.:/path/to/a/include/directory') in Unknown on line 0

Sometimes everything works fine, sometimes don't - without changing anything in the php.ini or httpd.conf . A few days ago I updated from php4.0.4 to php4.0.6 and after that the problems begann. 
All parameters in 4.0.6 are the same than in 4.0.4.

Do you need more informations?

Bye,
Sascha Emondts

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-29 11:53 UTC] se at brainbits dot net
Again I have this problem. Now it occurs on an Debian 3.0 with PHP4.3.3 and on a SuSE 7.2 with PHP4.3.2 - both with  	Apache/1.3.26.

But the error-message changed a little bit:

Warning: Unknown(prepend.php4): failed to open stream: No such file or directory in Unknown on line 0
Warning: (null)(): Failed opening 'prepend.php4' for inclusion (include_path='.:/www/user1/inc') in Unknown on line 0

Curios: there is no auto_prepend-file and there is no script which includes a file called "prepend.php4" in the host enviroment of user1. There is another user with another virtual hosts who uses a auto_prepend_file called "prepend.php4". But why does this takes effect on the host of user 1?

Bye,
Sascha
 [2003-09-29 21:03 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #23580 (same issue, vhost specific php settings leaked)

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 22:05:53 2023 UTC