php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12954 imap_uid does not return the uid
Submitted: 2001-08-24 21:48 UTC Modified: 2001-08-24 22:08 UTC
From: dev0987 at yahoo dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.0.6 OS: Windows NT 4, SP6
Private report: No CVE-ID: None
 [2001-08-24 21:48 UTC] dev0987 at yahoo dot com
This same bug was reported in bug#7486 and its current status is "Bogus", that's why I'm reporting this problem again.

Base on RFC1939 (Post Office Protocol - Version 3), a command UIDL can be used to retrieve the "unique-id".

According to RFC1939:
"The unique-id of a message is an arbitrary server-determined string, consisting of one to 70 characters in the range 0x21 to 0x7E, which uniquely identifies a message within a maildrop and which persists across sessions.  This
persistence is required even if a session ends without
entering the UPDATE state.  The server should never reuse an
unique-id in a given maildrop, for as long as the entity
using the unique-id exists."

Although UIDL is an optional command, most POP3 server do support it.  In fact most POP3 email clients expect it.

The unique id supplied by UIDL is  NOT a "Message-ID" in the message header.  In fact, "Message-ID" uniqueness can not always be guranteed.

Please do check into this again, because without imap_uid() funtioning properly, imap_ functions? usefulness for POP3 are significantly limited.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-24 22:08 UTC] joey@php.net
I'm not sure what's going on in #7486, but if you look
in the documentation for the IMAP c-client library, you'll
see the following entry in bugs.txt:
No POP3 UID support

At least, that's the word up until imap-200a's c-client, which
is the latest I have been able to find...

Not a PHP bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 19:03:38 2021 UTC