php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12950 cannot load libphp4.so into server...
Submitted: 2001-08-24 15:13 UTC Modified: 2001-08-25 05:31 UTC
From: lwillmann at mailcity dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.0.6 OS: Red Hat 7.1 i686
Private report: No CVE-ID: None
 [2001-08-24 15:13 UTC] lwillmann at mailcity dot com
Compiled using:
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--enable-versioning \
--with-mysql=/usr/local/mysql \
--enable-track-vars \
--with-imap=/usr/local/imap-2001.BETA.SNAP-0108162300 \
--with-gd \
--with-ldap \
--enable-ftp \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--with-gettext \
--with-openssl \
--with-mm=/usr/local/lib/mm
--with-jpeg-dir=/usr/lib

It compiles, makes, and installs fine. But when I try to 
fire up apache with the module loading.. I get an error 
message:
Syntax error on line 212 of 
/usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into 
server: libmm.so.11: cannot load shared object file: No 
such file or directory
/etc/rc.d/init.d/apachectl start: httpd could not be 
started

This is a paste of the EXACT message I am receiving. I 
need PHP to get data out of a mysql database, everything 
else with PHP is just gravy. I was following a how-to, and 
everything else worked ok.. But this. Any help is 
appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-25 05:31 UTC] sniper@php.net
Please ask support questions on the mailing lists:

http://www.php.net/support.php

(Hint: your /etc/ld.so.conf doesn't have the entry
for /usr/local/lib/mm/lib or whatever the path to
libmm.so is. Add that and run /sbin/ldconfig )

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 09:01:23 2020 UTC