php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12931 Cannot use http:// url in xslt_run
Submitted: 2001-08-23 13:23 UTC Modified: 2001-09-03 14:31 UTC
From: darron at javelindigital dot com Assigned:
Status: Not a bug Package: Sablotron XSL
PHP Version: 4.0.6 OS: Linux 2.2.19
Private report: No CVE-ID: None
 [2001-08-23 13:23 UTC] darron at javelindigital dot com
This works fine:

<?php 

$processor = xslt_create();
xslt_run($processor, 'diary.xsl', 'test.xml');
print xslt_fetch_result($processor);
xslt_free($processor);

?>

This doesn't work:

<?php 

$processor = xslt_create();
xslt_run($processor, 'diary.xsl', 
'http://baby.froese.org/baby.xml');
print xslt_fetch_result($processor);
xslt_free($processor);

?>

I get this error:

Fatal error: cannot read from URI 
'http://baby.froese.org/baby.xml' in 
/home/darron/public_html/xslt.php on line 4

That URI exists and validates just fine.

I've tried this on multiple machines (Linux, Apache 
1.3.19/20, expat-1.95.2, sablotron-0.65) running PHP 4.0.6 
and 4.0.7RC1 and they fail:

PHP 4.0.7RC1 compiled:

./configure \
--with-apxs=/usr/local/apache_1.3.19/bin/apxs \
--with-mysql=/usr/local/mysql-3.23.38 \
--with-pgsql=/usr/local/pgsql-7.1.2 \
--enable-ftp \
--with-curl \
--with-zlib \
--with-pspell \
--with-ldap \
--with-pdflib=/usr/local/pdflib-4 \
--with-imap=/usr/local/src/imap-4.5 \
--with-zlib-dir=/usr/lib \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-gd \
--with-ttf \
--with-t1lib \
--with-xml \
--with-swf=/usr/local \
--with-ming \
--with-sablot \
--with-xslt-sablot \
--enable-sablot-errors-descriptive \
--with-expat-dir=/usr \
--with-java=/usr/local/jdk \
--with-gettext \
--with-mcrypt \
--with-mhash \
--enable-wddx \
--enable-sockets \
--enable-calendar \
--enable-trans-sid \
--enable-track-vars=yes \
--enable-magic-quotes=yes

PHP 4.0.6 compiled:

./configure \
--with-apxs=/usr/local/apache_1.3.20/bin/apxs \
--with-mysql=/usr/local/mysql-3.23.39 \
--with-pgsql=/usr/local/pgsql-7.1.2 \
--with-pdflib=/usr/local/pdflib-4 \
--with-curl \
--enable-ftp \
--with-ldap \
--with-imap=/usr/local/src/imap-4.5 \
--with-zlib \
--with-jpeg-dir=/usr/lib \
--with-tiff-dir=/usr/lib \
--with-zlib-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-gd \
--with-ttf \
--with-xml \
--with-sablot \
--with-xslt-sablot \
--with-sybase=/usr/local/sybase \
--enable-trans-sid \
--enable-track-vars=yes \
--enable-magic-quotes=yes \
--enable-inline-optimization

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-03 14:30 UTC] sterling@php.net
Not a PHP bug, report to the Sablotron Folks....
 [2001-09-03 14:31 UTC] sterling@php.net
Sorry Jani :)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Sep 19 17:01:42 2019 UTC