php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12888 garbage collector
Submitted: 2001-08-22 06:11 UTC Modified: 2001-08-22 06:16 UTC
From: aoudin at hotmail dot com Assigned:
Status: Not a bug Package: Session related
PHP Version: 4.0.6 OS: Win2000
Private report: No CVE-ID: None
 [2001-08-22 06:11 UTC] aoudin at hotmail dot com
Is the garbage collector function for sessions working?
I have put the gc probability to 1, a lifetime of session of 1 second (minute?).
But there's still session's file on my hard drive.
I have made several tests and not even one of them have been deleted.

Could you tell me if it is a known issue.

Regards,
Alexandre OUDIN
ASP/PHP Developper - ConnectWorld

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-22 06:16 UTC] sniper@php.net
Propability 1 means: 1% propability that the garbage
collection starts. So it hardly ever happens.

Try changing the propability to 100 (= 100%) 
and you'll see that now the session files are
deleted every every time you reload the page
having 'session_start()' in it.

Not a bug.

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 05:01:29 2024 UTC